This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 232039 - using wlan0 instead of eth1
using wlan0 instead of eth1
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: wpa_supplicant (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-13 14:02 EDT by cje
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-22 11:02:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description cje 2007-03-13 14:02:19 EDT
Description of problem:
when i attempt to start the wpa_supplicant service it produces a set of ioctl
"No such device" errors and says "Could not set interface 'wlan0' UP".  but my
wireless interface has already been assigned the name 'eth1' by the default install.

Version-Release number of selected component (if applicable):
0.4.9-1.fc7

How reproducible:
always

Steps to Reproduce:
1. start wpa_supplicant service
2.
3.
  
Actual results:
ioctl errors

Expected results:
no errors

Additional info:
this is an old toshiba portege p2000 laptop using the hermes/orinoco/orinoco_cs
drivers.
Comment 1 Dan Williams 2007-03-13 14:15:28 EDT
This is a kernel issue; I believe that the 'hostap' driver got bound to your
orinoco card rather than the 'orinoco' driver.  They both have some overlap in
the hardware they support, and it's a crapshoot which driver gets loaded first.

You should probably add the following lines to /etc/modprobe.d/blacklist:

blacklist hostap
blacklist hostap_cs
blacklist hostap_plx
blacklist hostap_pci

Comment 2 cje 2007-03-13 14:24:15 EDT
hmm.  even if lsmod | grep hostap returns nothing?
Comment 3 cje 2007-03-13 14:38:30 EDT
just reading through kismet's readme and they seem to think that the orinoco
driver is _supposed_ to produce ethX interfaces.  they also seem to be saying
that various other drivers create a whole host of other interface names.  they
mention wlanX for atmel_usb, hostap, nokia770, wlanng* and zd1211.

maybe i should be blacklisting orinoco?  does wpa_supplicant know something
modprobe doesn't?!  oh, how do i find out what the wireless device really is? 
all i can see in lspci is a cardbus bridge.  how do i see what's on the other
side of the bridge?

(i tried the blacklist suggestion anyway - no change)
Comment 4 John W. Linville 2007-03-19 11:31:56 EDT
Can you post the contents of either/both 
of /etc/sysconfig/network-scripts/ifcfg-{wlan0,eth1} (whichever you've got, or 
both)?
Comment 5 cje 2007-03-19 11:35:13 EDT
i've got ifcfg-eth1 and it goes like this:

# TOSHIBA Wireless LAN Card Version 01.01
DEVICE=eth1
ONBOOT=yes
BOOTPROTO=dhcp
HWADDR=00:02:2d:5d:93:0b
Comment 6 John W. Linville 2007-03-21 13:37:52 EDT
Dan, any idea how/why NM might be looking for wlan0 when only eth1 exists?
Comment 7 Dan Williams 2007-03-21 18:42:40 EDT
well, this sounds like wpa_supplicant not NM...

cje: how are you executing wpa_supplicant?  Can you post the command you're using?
Comment 8 cje 2007-03-21 21:27:24 EDT
yeah.  i was about to say.

at the moment i've just been starting it with:

service wpa_supplicant start

or it's auto-started on boot and i can see the messages just before it goes to
the login screen.

i'll post some more details tomorrow morning (well, in about 10 hours) when i've
had a look at how the service runs and where it's getting its config from.
Comment 9 Dan Williams 2007-03-22 07:46:14 EDT
Ok; I think the problem is that you have not edited
/etc/sysconfig/wpa_supplicant to set the correct interfaces and drivers.  Did
you turn the service on?
Comment 10 cje 2007-03-22 08:20:53 EDT
yep.  i just found that.  and yes, i did turn the service on.

right.  reading through the man page and looking at some web stuff looks like
orinoco_cs doesn't work with wpa_supplicant.

i've tried 'wpa_supplicant -Dwext -ieth1
-c/etc/wpa_supplicant/wpa_supplicant.conf' on the command line and get a bunch
of ioctl 'Function not implemented' messages and then it gets stuck at 'WEXT
auth param 5 value 0x1 -'.

i'm not sure what the answer to this is.  i can see what that default config is
trying to do (make it so that a lot of people don't have to manually configure
things) but i found it confusing.  perhaps the answer is just RTFM for now but
i'd personally prefer some helpful notification messages from NetworkManager or
something.

i'm sure it's possible for NetworkManager and wpa_supplicant to auto-configure
things between them but i can see that coding it might be a lot of work and
involve a lot of exceptions too.  hmm.
Comment 11 John W. Linville 2007-03-22 09:42:00 EDT
Maybe you should try blacklisting orinoco and loading hostap instead?
Comment 12 cje 2007-03-22 11:02:10 EDT
er.  okay.  is that sarcasm?  i'm not sure.  i was mostly joking when i
suggested that in comment #3.

i think i've managed it anyway but loading the hostap module produces nothing in
the system log.  loading hostap_cs produces a 'module loaded' type of message
but nothing more and no interface is created.  i'm pretty sure hostap can't deal
with this wifi card.  (system-config-network calls it TOSHIBA Wireless LAN Card
Version 01.01 (eth1)).

not sure if it's really my decision but i'm marking this as notabug cos i think
i should have read more docs.  if people want to reopen it or open a new one
about the wpa_supplicant default config then they're more than welcome to do so.

thanks for the help.  :-)
Comment 13 John W. Linville 2007-03-22 11:13:15 EDT
Sorry, didn't recall comment 3 when I wrote comment 10...

I guess NOTABUG is fine, since it is ultimately a configuration issue.  I 
suppose you could open a bug for WPA support in orinoco if you'd like.

Sorry we didn't get you working...
Comment 14 John W. Linville 2007-03-22 11:19:10 EDT
BTW, could you post the output of 'pccardctl ident'...maybe hostap_cs could 
work w/ your card if we added its ID?
Comment 15 cje 2007-03-22 11:38:05 EDT
aha!  and that's the answer to my question in comment #3 .. cheers!

and the answer is .. 
Socket 0:
  product info: "TOSHIBA", "Wireless LAN Card", "Version 01.01", ""
  manfid: 0x0156, 0x0002
  function: 6 (network)
Comment 16 cje 2007-03-22 13:32:54 EDT
so, is "added its ID" something i can try out?  i've had a look around the
intertubes and found some references to entries in a /etc/pcmcia/hostap_cs.conf
file but that doesn't seem to exist on this system and possibly isn't used anymore?

another path seemed to lead to udev settings in /etc/udev but i had a look at
the rules files and got scared.

so let me know if there's something i can try out.

cheers.

Note You need to log in before you can comment on or make changes to this bug.