Bug 23207 - atd fork bomb
atd fork bomb
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: at (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Crutcher Dunnavant
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-03 01:53 EST by Wesley Tanaka
Modified: 2007-04-18 12:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-03 05:00:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Excerpt from syslog messages (410.58 KB, text/plain)
2001-01-03 01:58 EST, Wesley Tanaka
no flags Details

  None (edit)
Description Wesley Tanaka 2001-01-03 01:53:58 EST
This is the version of "at" that I have installed:

~ % rpm -qi at
Name        : at                           Relocations: (not relocateable)
Version     : 3.1.8                             Vendor: Red Hat, Inc.
Release     : 13                            Build Date: Thu 14 Dec 2000
08:01:27 PM PST
Install date: Sun 24 Dec 2000 12:53:28 PM PST      Build Host:
porky.devel.redhat.com
Group       : System Environment/Daemons    Source RPM: at-3.1.8-13.src.rpm
Size        : 76060                            License: GPL
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
Summary     : Job spooling tools.
Description :
At and batch read commands from standard input or from a specified file.
At allows you to specify that a command will be run at a particular time
(now or a specified time in the future).  Batch will execute commands
when the system load levels drop to a particular level.  Both commands
use /bin/sh to run the commands.

You should install the at package if you need a utility that will do
time-oriented job control.  Note: you should use crontab instead, if it is
a recurring job that will need to be repeated at the same time every
day/week/etc.


At some point my system started thrashing a lot and, when I ran ps, I
noticed a lot of atd processes.

My syslog contains many entries of the following form:

Dec 20 10:47:00 altair atd[3874]: File a0007b00f88c5f is in wrong format -
aborting
Dec 20 10:47:00 altair atd[3875]: File a0007c00f88c60 is in wrong format -
aborting
Dec 20 10:47:00 altair atd[3876]: File a0007b00f88c5f is in wrong format -
aborting
Dec 20 10:47:00 altair atd[3877]: File a0007c00f88c60 is in wrong format -
aborting

I will attach an excerpt, later.

This was reproducable every time I (or init) started atd.

I unfortunately do not have the files in question, as I noticed the syslog
spooge much later than I clobbered /var/spool/at
Comment 1 Wesley Tanaka 2001-01-03 01:58:40 EST
Created attachment 6985 [details]
Excerpt from syslog messages
Comment 2 Crutcher Dunnavant 2001-03-29 11:20:11 EST
this looks like something in the at spool got corrupted on disk. reopen if you
see this again.

Note You need to log in before you can comment on or make changes to this bug.