Bug 232155 - silent crashes.
Summary: silent crashes.
Status: CLOSED DEFERRED
Alias: None
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
(Show other bugs)
Version: 6
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Adam Tkac
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-14 00:24 UTC by Dave Jones
Modified: 2015-01-04 22:29 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-14 13:22:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dave Jones 2007-03-14 00:24:21 UTC
About once a month, bind crashes on my home gateway.  I can't provide any
further details than this because there's nothing in the logs, and no core dump
anywhere (possibly because its running inside the chroot ?)

The symptom is that it just stops running for no apparent reason.

Any ideas how I can debug this?

Comment 1 Adam Tkac 2007-03-14 09:18:24 UTC
Hm, it isn't easy to debugging. Best way I think could be increase named's debug
level (-d option, number about 20) and move named out from chroot and run it
with selinux protection (selinux protection is more secure than chroot). Outsite
of chroot we could get core dump and find where problem is.. Tell me your decision.

Adam

Comment 2 Dave Jones 2007-03-14 13:12:04 UTC
I added -d 20 to the init script, is there a toggle in a config file somewhere
to disable the chroot stuff ?


Comment 3 Dave Jones 2007-03-14 13:22:34 UTC
never mind, I figured it out, I removed it -t from the command line.
Seems to be working for now. I'll open up another bug if it crashes some time.

Thanks.



Note You need to log in before you can comment on or make changes to this bug.