Bug 232277 - libreadline not linked with libncurses
libreadline not linked with libncurses
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: readline (Show other bugs)
6
All Linux
high Severity high
: ---
: ---
Assigned To: Miroslav Lichvar
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-14 13:31 EDT by David Cantrell
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-15 11:03:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Cantrell 2007-03-14 13:31:44 EDT
While trying to compile a new parted release on FC-6, I received undefined
symbol messages when linking with libreadline:

/usr/lib/gcc/i386-redhat-linux/4.1.1/../../../libreadline.so: undefined
reference to `PC'
/usr/lib/gcc/i386-redhat-linux/4.1.1/../../../libreadline.so: undefined
reference to `tgetflag'
/usr/lib/gcc/i386-redhat-linux/4.1.1/../../../libreadline.so: undefined
reference to `tgetent'
/usr/lib/gcc/i386-redhat-linux/4.1.1/../../../libreadline.so: undefined
reference to `UP'
/usr/lib/gcc/i386-redhat-linux/4.1.1/../../../libreadline.so: undefined
reference to `tputs'
/usr/lib/gcc/i386-redhat-linux/4.1.1/../../../libreadline.so: undefined
reference to `tgoto'
/usr/lib/gcc/i386-redhat-linux/4.1.1/../../../libreadline.so: undefined
reference to `tgetnum'
/usr/lib/gcc/i386-redhat-linux/4.1.1/../../../libreadline.so: undefined
reference to `BC'
/usr/lib/gcc/i386-redhat-linux/4.1.1/../../../libreadline.so: undefined
reference to `tgetstr'

libreadline should be linked with libncurses since it requires that library. 
Adding -lncurses to the linker flags will work in some cases, but autoconf
'configure' scripts will fail over and over when searching for libreadline
because they will not necessarily add -lncurses to the linker flags.

This problem also affects rawhide.

I need this library fixed ASAP in rawhide so I can get a new parted merged in
for F7.
Comment 1 Miroslav Lichvar 2007-03-14 13:51:31 EDT
Unfortunately this isn't possible to do since libreadline can be linked with
libtermcap or libncurses or libncursesw. Linking readline with one library would
break applications that are linked with the other lib.
Comment 2 Miroslav Lichvar 2007-03-15 09:24:40 EDT
Hmm, we can actually link libreadline in rawhide with libtinfo as both
libncurses and libncursesw are now linked with the same libtinfo.

Note You need to log in before you can comment on or make changes to this bug.