Bug 232380 - Pod::Readme: BR'ing perl(Test::Pod::Coverage) creates a circular BR loop
Pod::Readme: BR'ing perl(Test::Pod::Coverage) creates a circular BR loop
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: perl-Pod-Readme (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steven Pritchard
Fedora Extras Quality Assurance
:
Depends On:
Blocks: perl_5.10
  Show dependency treegraph
 
Reported: 2007-03-14 23:07 EDT by Chris Weyl
Modified: 2008-03-10 22:21 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-10 22:21:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Weyl 2007-03-14 23:07:52 EDT
Another fun circular BR loop :)

Though this is seen when trying to rebuild perl-Module-Build:

perl-Module-Build BR's perl(Pod::Readme)
perl-Pod-Readme BR's perl(Test::Pod::Coverage)
perl-Test-Pod-Coverage BR's perl(Pod::Coverage)
perl-Pod-Coverage BR's perl(Module::Build)

Since Test::Pod::Coverage is a developer test, and not needed for the build of
perl-Pod-Readme, can we drop it as a BR to this package?
Comment 1 Steven Pritchard 2007-11-27 09:59:52 EST
Haven't we broken this circular dependency already by not BR'ing Pod::Readme in
Module::Build (bug #215558)?
Comment 2 Chris Weyl 2008-03-10 22:21:58 EDT
Sounds good to me...

Note You need to log in before you can comment on or make changes to this bug.