Bug 23240 - Update Agent fails with authenticated proxies
Summary: Update Agent fails with authenticated proxies
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date   
(Show other bugs)
Version: 6.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-03 18:52 UTC by Hassan Aurag
Modified: 2015-01-07 23:42 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-26 23:48:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2001:048 normal SHIPPED_LIVE New Update Agent with many fixes and enhanced functionality available 2001-04-12 04:00:00 UTC

Description Hassan Aurag 2001-01-03 18:52:56 UTC
These are 2 bugs actually. 

 The first is easy to correct. Look at line 659 of
/usr/share/rhn/up2date/gui.py. There you use self.fatalError(_("There was a
fatal error.... in the main() function. Self of course here means nothing
and is an error. I think you meant gui() here, but then you create the
instance later. SO maybe you should move the fatal_error out of gui() or
something.


 The second is more serious at least for me. It seems no firewall proxy
support exists for RedHat Network. Would that be very hard to add? I am
talking here about web proxy (firewall) with authentication.


 The up2date and rhn versions are:
	up2date-2.1.7-0.6.x
	rhn_register-1.0.2-0.6.x
	rhn_register-gnome-1.0.2-0.6.x
	up2date-gnome-2.1.7-0.6.x
	python-xmlrpc-1.2.1-0.6.x

Comment 1 Adrian Likins 2001-02-08 05:48:50 UTC
Proxy support should be enabled and working in the 
errata versions of up2date and rhn_register.

There are config directives in /etc/sysconfig/rhn/up2date
that will allow you to configure the proxy settings.

You can also alternatively use use `up2date --configure`.

Looks like you are right about the self.fatalError line.
Will fix in the next release. Thanks for the catch.

Comment 2 Hassan Aurag 2001-02-12 16:32:53 UTC
 For Proxy, I am talking about Firewall HTTP Proxy that is a authenticated proxy
for all network protocols including http-ftp-ssl, and this one does not work.
Trust me.

 I get an error in sockets or whatever that is. No authentication is done ....


Comment 3 Cristian Gafton 2001-02-20 01:34:07 UTC
Assigned QA to jturner

Comment 4 Preston Brown 2001-04-12 20:58:23 UTC
addressed in errata due out today.


Note You need to log in before you can comment on or make changes to this bug.