Bug 232416 - consider splitting the spell checking dictionaries of openoffice.org-dict-cs_CZ into a "hunspell-cs" package
consider splitting the spell checking dictionaries of openoffice.org-dict-cs_...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: openoffice.org-dict-cs_CZ (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-15 08:57 EDT by Caolan McNamara
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: openoffice.org-dict-cs_CZ-20060303-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-27 06:50:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Caolan McNamara 2007-03-15 08:57:14 EDT
Description of problem:

openoffice.org-dict-cs_CZ contains the hyphenation and spellchecker dictionaries
for openoffice.org for Czech.

But since this package was started we have now split all the dictionaries out of
OpenOffice.org and into separate "hunspell-language" packages, e.g. see
hunspell-da for Danish. 

If the openoffice.org-dict-cs_CZ is split so that the spell checking
dictionaries are "hunspell-cs" (e.g. just follow the rest of the hunspell-lang
src.rpm patterns) then we get 
a) a more consistent naming scheme for the dictionaries
b) automatically Czech will be available to firefox when it integrates the
forthcoming upgrade to using hunspell. 
c) there's no need for any special triggers for installing spellchecking
dictionaries requires, their mere presence according to the naming scheme of
cs_CZ.aff and cs_CZ.dic in the /usr/share/hunspell dictionary will make OOo see them

Hyphenation dictionaries are not affected by this split of the spellchecking
dictionaries, they still need the messy trigger. Note that OOo for FC-7 is now
in /usr/lib/openoffice.org so you need to change your .spec anyway to track the
new (final) location of OOo.

Version-Release number of selected component (if applicable):
openoffice.org-dict-cs_CZ-20060303-4.fc7
Comment 1 Tomas Mraz 2007-03-26 16:15:45 EDT
In the current hunspell-en-0.20040623-1 the installation directory is actually
/usr/share/myspell. Is this a final location for Fedora 7?
Comment 2 Caolan McNamara 2007-03-27 03:27:58 EDT
yeah, hunspell defaults to looking into this directory for dictionaries because
it is based on "myspell" which defaulted to that location. hunspell understands
the myspell format as well as it's hunspell extended format.
Comment 3 Tomas Mraz 2007-03-27 03:33:34 EDT
So should I use /usr/share/myspell or /usr/share/hunspell?
Comment 4 Caolan McNamara 2007-03-27 04:19:54 EDT
/usr/share/myspell
Comment 5 Tomas Mraz 2007-03-27 06:50:44 EDT
I've added the hunspell-cs subpackage in current Fedora development packages.

Note You need to log in before you can comment on or make changes to this bug.