Bug 232525 - X60s does not boot with nmi_watchdog=1
X60s does not boot with nmi_watchdog=1
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Brian Maly
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-15 19:22 EDT by Matthew Booth
Modified: 2007-12-11 14:16 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-11 14:16:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Booth 2007-03-15 19:22:18 EDT
Description of problem:
If I add nmi_watchdog=1 to the kernel command line when booting, it hangs
forever at:

ACPI: Found ECDT

This is *almost* 100% guaranteed. There seems to be a rain dance you can do to
get it to boot. It goes something like:

* Remove the power cord
* Boot the laptop
* Wait for grub
* Re-insert power cord while grub is still running

However once the laptop is up, if you remove the power cord, reinserting it will
cause the laptop to hang immediately and automatically reboot after a few
seconds. Removing nmi_watchdog=1 causes the problem to go away. The xen kernel
boots fine with or without nmi_watchdog=1.

Version-Release number of selected component (if applicable):
kernel-2.6.18-8.1.1.el5
Comment 1 Patrick C. F. Ernzer 2007-03-28 05:33:20 EDT
same hang on X60 with Core2Duo (type 1706-GMG)
did not bother trying the rain dance
Comment 2 Patrick C. F. Ernzer 2007-03-28 05:34:27 EDT
Forgot to add in Comment #1:
This is with the x86_64 version of RHEL5
Comment 3 Jarod Wilson 2007-09-12 12:05:06 EDT
Does this still occur with the latest RHEL5.1 beta kernels? If so, can the
problem be reproduced with a recent Fedora kernel? (i.e., is there a fix
upstream we need to hunt down?)
Comment 4 Patrick C. F. Ernzer 2007-09-12 12:58:39 EDT
On 1706-GMG with Fedora rawhide x86_64 and kernel 2.6.23-0.164.rc5.fc8 I still
cannot boot if I use nmi_watchdog=1. Machine boots fine without this.
Comment 5 CAI Qian 2007-10-03 05:21:36 EDT
I have seen the same problem on my laptop T43 + i386 + RHEL5-Client, but I have
seen it when bootting kernel 2.6.18-8.1.8.el5PAE with parameter including both
"nmi_watchdog=1" and "crashkernel=128M@16M". If substituting with
"nmi_watchdog=2" or without "crashkernel" para, there is no problem as well. I
can confirm that there is no such problem when running kernel 2.6.18-8.el5.
Comment 6 CAI Qian 2007-10-03 05:23:52 EDT
I have tried on the latest released 5.0.z kernel, 2.6.18-8.1.14.el5, and the
problem is still there.
Comment 7 CAI Qian 2007-10-03 21:42:06 EDT
I have observed the same hang even in 2.6.18-8.el5, but only when attached a USB
disk and had "nmi_watchdog=1" before booting.
Comment 8 Brian Maly 2007-11-29 14:58:58 EST
Does this problem occur on the X60 if "nmi_watchdog=2" is used instead?
Comment 9 Patrick C. F. Ernzer 2007-12-03 08:08:26 EST
FWIW: X60 with Core2Duo (type 1706-GMG) and Fedora 8, kernel x86_64 2.6.23.1-49.fc8
  nmi_watchdog=1 still does not boot
  nmi_watchdog=2 does boot (although
/usr/share/doc/kernel-doc-2.6.23/Documentation/nmi_watchdog.txt tells me this
should not work)
Comment 10 Brian Maly 2007-12-03 14:23:19 EST
Using nmi_watchdog=2 is fine as long as NMI in /proc/interrupts increments
perodically. The docs on NMI are very vague. nmi_watchdog is very hardware
specific. Some hardware only works with nmi_watchdog=1 and other hardware only
works with nmi_watchdog=2. Predicting which to use on which hardware really is
more of a guessing game.

Can you see if NMI increments in /proc/interrupts if nmi_watchdog=2 is used?

That being said, the hanging at "ACPI: Found ECDT" may be a seperate issue. Some
of these thinkpads had ACPI problems relating to ACPI battery state object
breakage. I see that in Comment #1 that removing the power cord sometimes makes
a difference. It seemes related so I figured I would mention it.
Comment 11 Don Zickus 2007-12-04 10:21:59 EST
Upstream is trying to deprecate nmi_watchdog=1, as the preferred method is to
use the local apic (nmi_watchdog=2) as opposed to the ioapic (nmi_watchdog=1). 
It's no surprise nmi_watchdog=1 doesn't work upstream on a Core2Duo.

Also, RHEL-5.0 the nmi won't work on Core2Duo, you will need RHEL-5.1 due to bz
221671.  But I haven't heard of any reports of ACPI issues when using different
nmi settings.
Comment 12 Patrick C. F. Ernzer 2007-12-04 10:51:20 EST
Matthew,
do you still have RHEL 5(.1) on the affected box and can you test? Mine is F8
x86_64, so my testing is only of limited value
Comment 13 Jarod Wilson 2007-12-04 11:08:40 EST
Note that there's nothing stopping you from installing and booting a RHEL5 kernel on an F8 system for 
the purposes of this test...
Comment 14 Matthew Booth 2007-12-04 17:03:43 EST
I'm currently running kernel 2.6.18-53.1.4.el5 (5.1), i386, on the laptop I
originally reported this on. Following previous discussion, I have booted with
the following kernel command line:

ro root=/dev/vg_local/root crashkernel=64M@16M audit=1 nmi_watchdog=2

This worked fine for me the 1 time I've tried it.

Note You need to log in before you can comment on or make changes to this bug.