This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 23256 - xscanimage says "xscanimage is a gimp plug-in..."
xscanimage says "xscanimage is a gimp plug-in..."
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: gimp (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-03 18:02 EST by Jonathan Kamens
Modified: 2007-04-18 12:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-16 14:34:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Here's a patch to make xscanimage say 'ignore this:' first. (1.18 KB, patch)
2001-01-04 08:56 EST, Tim Waugh
no flags Details | Diff

  None (edit)
Description Jonathan Kamens 2001-01-03 18:02:04 EST
I just upgraded to gimp-1.1.25-1 and sane-1.0.3-2.  Now, whenever I run
xscanimage from the command line, it prints, "xscanimage is a gimp plug-in
and must be run by the gimp to be used," then it starts up as it used to. 
It's supposed to be runnable from the command line OR from inside gimp, so
I don't understand why it's printing this message, and since it IS printing
this message, I don't understand why it's starting up.
Comment 1 Tim Waugh 2001-01-04 08:55:55 EST
The trick that xscanimage uses to shut gimp_main up (installing a no-nothing
print function) no longer works.
Comment 2 Tim Waugh 2001-01-04 08:56:55 EST
Created attachment 7043 [details]
Here's a patch to make xscanimage say 'ignore this:' first.
Comment 3 Tim Waugh 2001-01-08 10:11:10 EST
Hmm, on seconds thoughts this seems to be a deficiency on gimp's part.  xmorph
has the same trouble, for example.
Comment 4 Matt Wilson 2003-10-16 14:34:05 EDT
I don't think this is a problem anymore.

Note You need to log in before you can comment on or make changes to this bug.