Bug 23262 - Keyboard selector hangs
Keyboard selector hangs
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
Florence Gold
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-03 20:11 EST by Brian Ginter
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-17 15:09:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Ginter 2001-01-03 20:11:09 EST
When navigating anaconda with a keyboard, on the keyboard selection 
screen, scrolling through the keyboard choices will hang as soon as 
PC-98xx series is highlighted. You can no longer scroll through the list.
Comment 1 Michael Fulbright 2001-01-09 17:56:19 EST
Assigning to a developer.
Comment 2 Brent Fox 2001-01-10 18:03:32 EST
I've reproduced this bug.  Thanks for your report.  What's happening is that the
keymap for PC-98xx is being loaded when it is selected.  This appears to disable
the arrow keys as well as the Num Lock and Caps Lock keys...maybe other keys
too.  I'm not sure why this is happening.  Something seems to be wrong with the
PC-98xx keymap.
Comment 3 Glen Foster 2001-01-11 16:03:30 EST
This defect is considered MUST-FIX for Florence Gold release
Comment 4 Brent Fox 2001-01-12 11:51:37 EST
Here's the situation.  Currently, the keymap is applied immediately when you
make a selection in the model, layout, or dead key windows.  I've changed the
behavior so that the selection is not applied until you either click in the
Entry widget to test the selection or click the "Next" button.  This way, if you
are using the keyboard to scroll down to the Winbook Model XP5 keyboard, the
widget will not freeze on you.

However, there's still a problem.  If you select PC-98xx and then tab down to
the test selection screen, you can <TAB> the focus back to the model widget, but
you can't use the arrows to scroll it because the PC-98xx keymap disables the
arrow keys on a conventional keyboard.  To fix this, we need some sort of reset
button that loads a generic keymap.  However, that's more work than it's worth
at this point, so I'm deferring to a future date.
Comment 5 Michael Fulbright 2001-09-17 15:09:30 EDT
Brent please verify against enigma
Comment 6 Brent Fox 2001-09-18 15:30:38 EDT
This was fixed by mharris a few months ago.

Note You need to log in before you can comment on or make changes to this bug.