Bug 232662 - kernel panic: init not found
Summary: kernel panic: init not found
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-16 15:15 UTC by tjustt
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-23 13:34:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
audit.log (2.58 MB, text/plain)
2007-03-18 07:42 UTC, tjustt
no flags Details

Description tjustt 2007-03-16 15:15:55 UTC
Description of problem:
When i updated my kernel to 2.6.20-1.2986 and with newer ones i have been
getting these lines when starting my system:

Failed to execute /init
Kernel panic - not syncing: No init found. Try passing init= option to kernel

I can start my system with 2.6.20-1.2985 kernel but with newer ones it halts to
that kernel panic.

Version-Release number of selected component (if applicable):
2.6.20-1.2986 and newer

How reproducible:
every time

Additional info:

When i updated my system with smart in text environment i also got these lines
when installing kernel:

buffer I/O error on device fd0, logical block 0
end_reguest: I/O error, dev fd0, sector0

it duplicates those lines many times and after it comtinues installing other
updates.

Comment 1 Darwin H. Webb 2007-03-16 23:46:31 UTC
Received this message today on 2990

Failed to execute /init
Kernel panic - not syncing: No init found. Try passing init= option to kernel

First FC7 kernel not to boot on this Pent III 800 EB, 1GB PC133,
via Appollo-133, IDE , FX5200


Almost every kernel since 2925 has failed on my Pent IV ht 2.4c, Intel865BGF,
and requires several boots with guessing at parms (such as)
nohotplug nofirewire nopcmcia noapci nousb irqpoll
2987 and 2990 are running with these nohotplug nofirewire nopcmcia noapci
But I think it is completely random and luck to get it started.

Darwin

P.S. What would one pass on the init= ?
3 doesn't work.
/sbin/initab ?
or is it just broken?


Comment 2 Adam Goode 2007-03-17 22:35:58 UTC
Same thing with me. The last kernel that I have working is 2962. I have an ahci
SATA controller.

Comment 3 Dave Jones 2007-03-18 00:13:45 UTC
This was mentioned on Fedora list.  SELinux is preventing mkinitrd from
constructing a correct initrd.

Remove the latest kernel, setenforce 0, and then reinstall the kernel, and it
should work.

If it does, paste the AVC messages here (They'll either be in
/var/log/audit/audit.log if you have auditd running, or they'll be in dmesg)

Comment 4 tjustt 2007-03-18 07:42:30 UTC
Created attachment 150326 [details]
audit.log

Comment 5 tjustt 2007-03-18 07:48:09 UTC
It worked but still got that I/O error and can't mount my external hard drive
because it isn't in active session or should i make a new bug report about it,
since looks like it isn't related to this problem?

Comment 6 Christopher Aillon 2007-03-19 20:43:47 UTC
fixed for me in selinux-policy-2.5.8-8.fc7

Comment 7 Will Woods 2007-03-22 17:01:25 UTC
tjustt: If the 'init not found' problem is gone, please close this bug. The 'I/O
error' is a different issue.


Note You need to log in before you can comment on or make changes to this bug.