Bug 232687 - configurable http://, ftp:// sources for pup, pirut
configurable http://, ftp:// sources for pup, pirut
Status: CLOSED DUPLICATE of bug 212941
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
6
noarch Linux
medium Severity low
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-16 13:03 EDT by colin j lambert
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-19 18:18:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description colin j lambert 2007-03-16 13:03:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.0.10) Gecko/20070313 Fedora/1.5.0.10-5.fc6 Firefox/1.5.0.10

Description of problem:
futurefeature req:
Using pup and pirut is often very slow due to transfer rates from preset sources.  With the abundance of reliable mirrors available, it would be nice to be able to configure the http or ftp source that is used by pup or pirut.  I am unsure as to whether these programs choose between available mirrors, but often the transfer rates shown in a network monitor are relatively low, I assume due to high network traffic from the file servers.  Being able to select a mirror for these programs to use (especially in the case of there being a mirror on the LAN used for access) would increase the reliability of these apps, as they go into a sleeping state on the process monitor from what appears to be a limited network connection to the file servers being used.  I have experienced problems with pup especially going to idle due to limited connectivity.

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes


Steps to Reproduce:
1.trying to apply updates
2.check network monitor, low transmission rate
3.application goes into idle, can become unresponsive

Actual Results:
Pup, Pirut can become unresponsive

Expected Results:


Additional info:
Comment 1 Jeremy Katz 2007-03-19 18:18:31 EDT

*** This bug has been marked as a duplicate of 212941 ***

Note You need to log in before you can comment on or make changes to this bug.