Bug 232689 - Dead keys do not work.
Dead keys do not work.
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: emacs (Show other bugs)
5.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Chip Coldwell
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-16 13:19 EDT by Göran Uddeborg
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-02 10:04:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Göran Uddeborg 2007-03-16 13:19:09 EDT
Description of problem:
Whenever I press any dead key, like dead-tilde, in emacs, it just beeps.  If I
do C-h k dead-tilde emacs says "<dead-tilde> is undefined".

I have a Swedish keyboard, and my locale is sv_SE.  (Or sv_SE.utf8, the effect
is the same in both.)

Version-Release number of selected component (if applicable):
emacs-21.4-18.1.el5

How reproducible:
Every time.

Steps to Reproduce:
1.Start emacs
2.Type dead-tilde

Actual results:
A beep

Expected results:
A tilde over the following character (if appropriate).

Additional info:
This looks similar to bug 224646, but that one was about emacs 22, so I'm not
sure how connected they are.  In any case, that one was about Fedora devel and
is closed, while this problem exists today in the emacs of RHEL 5.
Comment 1 Chip Coldwell 2007-07-13 14:21:29 EDT
(In reply to comment #0)
> Description of problem:
> Whenever I press any dead key, like dead-tilde, in emacs, it just beeps.  If I
> do C-h k dead-tilde emacs says "<dead-tilde> is undefined".
> 
> I have a Swedish keyboard, and my locale is sv_SE.  (Or sv_SE.utf8, the effect
> is the same in both.)
> 
> Version-Release number of selected component (if applicable):
> emacs-21.4-18.1.el5
> 
> How reproducible:
> Every time.
> 
> Steps to Reproduce:
> 1.Start emacs
> 2.Type dead-tilde
> 
> Actual results:
> A beep
> 
> Expected results:
> A tilde over the following character (if appropriate).
> 
> Additional info:
> This looks similar to bug 224646, but that one was about emacs 22, so I'm not
> sure how connected they are.  In any case, that one was about Fedora devel and
> is closed, while this problem exists today in the emacs of RHEL 5.

What happens if you run

M-x iso-accents-mode

?

Chip
Comment 2 Göran Uddeborg 2007-08-02 09:31:58 EDT
Now I'm confused.  I can't reproduce this any more.  I'm not sure what has
changed, but dead keys work again in emacs.  We are still running
emacs-21.4-18.1.el5, but maybe something around it was upgraded.  It's the only
RHEL5 machine here yet, so I have no other to compare with.

By the way, the similar emacs 22 bug is bug 224626, not the one I wrote in
comment 0.
Comment 3 Chip Coldwell 2007-08-02 10:04:50 EDT
(In reply to comment #2)
> I can't reproduce this any more.

In that case, I'll close the bug.  If it starts happening again, you can re-open it.

Chip

Note You need to log in before you can comment on or make changes to this bug.