Bug 232690 - broken IPv6 prefix after manual TCP/IP configuration
broken IPv6 prefix after manual TCP/IP configuration
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-16 13:29 EDT by Dawid Gajownik
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-23 14:26:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
my configuration (73.63 KB, image/jpeg)
2007-03-16 13:29 EDT, Dawid Gajownik
no flags Details
ifconfig output - configured IPv6 address is not set (66.26 KB, image/jpeg)
2007-03-16 13:31 EDT, Dawid Gajownik
no flags Details
eth0 configuration - please take a look at the two slashes (45.16 KB, image/png)
2007-03-16 13:32 EDT, Dawid Gajownik
no flags Details
after clicking on Edit button - IPv6 prefix is not set (53.01 KB, image/jpeg)
2007-03-16 13:33 EDT, Dawid Gajownik
no flags Details

  None (edit)
Description Dawid Gajownik 2007-03-16 13:29:40 EDT
Description of problem:
http network install using todays boot.iso image - after manual IPv6
configuration IPv6 address and prefix are not set. Please see attached photos.
Comment 1 Dawid Gajownik 2007-03-16 13:29:40 EDT
Created attachment 150255 [details]
my configuration
Comment 2 Dawid Gajownik 2007-03-16 13:31:24 EDT
Created attachment 150256 [details]
ifconfig output - configured IPv6 address is not set
Comment 3 Dawid Gajownik 2007-03-16 13:32:47 EDT
Created attachment 150257 [details]
eth0 configuration - please take a look at the two slashes
Comment 4 Dawid Gajownik 2007-03-16 13:33:39 EDT
Created attachment 150258 [details]
after clicking on Edit button - IPv6 prefix is not set
Comment 5 Dawid Gajownik 2007-03-16 13:41:21 EDT
Installation did not finished (bug #232639) but you can notice in this backtrace
→ https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=150226 that IPV6ADDR
variable is set to "2a01:1d8:1:30::b2/64". On my FC6 box network scripts use
also IPV6PREFIX variable to define IPv6 prefix.
Comment 6 David Cantrell 2007-03-21 16:27:06 EDT
There are several different bugs listed in this report.  In the future, please
file separate bugs for different issues.  Even if they seem related, please file
separate bugs.

First, can you try booting rawhide again.  When it comes to the first network
configuration screen, disable IPv4 and only select IPv6.  Tell it to do manual.
 Does the IPv6 get set at that point?
Comment 7 David Cantrell 2007-03-21 16:29:44 EDT
Reading through the libdhcp code, it looks like for static address
configuration, the function only handles one or the other.  It defaults to IPv4.
 I think that's going to be the issue.  Check anyway and post your findings.
Comment 8 Dawid Gajownik 2007-03-23 10:26:05 EDT
(In reply to comment #6)
> There are several different bugs listed in this report.  In the future,
> please file separate bugs for different issues.  Even if they seem related,
> please file separate bugs.

Well, I'm just a tester, not an Anaconda developer. I thought that it's caused
by the same problem. Sorry, next time I'll try to do it better.

> First, can you try booting rawhide again.  When it comes to the first network
> configuration screen, disable IPv4 and only select IPv6.  Tell it to do
> manual. Does the IPv6 get set at that point?

I tried it and it does not work, either (this time ftp installation,
anaconda-11.2.0.40). Anaconda tries to download images but it fails. It's
strange a bit because it does not inform me that it failed (like with broken
ftp/path configuration) - it only shows ftp configuration once again.

I cannot ping6 static IP address from other host. If I ping6 that one set by
autoconfiguration I get reply, though. I'm not sure whether it's important but
on the console there is such a message:

<6>eth0: duplicate address detected!

I'm sure that IPv6 address which I set on eth0 is not used by any other host.

Without IPv4 and with IPv6 autoconfiguration I can download stage2.img.
Comment 9 David Cantrell 2007-03-23 14:26:03 EDT
I think I have this problem solved.  I had to fix libdhcp and build a new one
(1.24) and then patch loader in anaconda to work around some other things.  But
I think it's solved.  Closing as rawhide.  These changes will appear in the next
rawhide anaconda build.  Note that rawhide is currently locked down for F7T3,
but once it opens back up, changes will appear there.

Note You need to log in before you can comment on or make changes to this bug.