Bug 232748 - X crashes during logout on x86_64 system with i945 graphics and XD disabled
X crashes during logout on x86_64 system with i945 graphics and XD disabled
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jarod Wilson
Martin Jenner
https://bugs.freedesktop.org/show_bug...
:
Depends On:
Blocks: RHEL5u2_relnotes 425461
  Show dependency treegraph
 
Reported: 2007-03-16 22:30 EDT by Jay Lee
Modified: 2008-05-21 10:41 EDT (History)
4 users (show)

See Also:
Fixed In Version: RHBA-2008-0314
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 10:41:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org (Old) 5085 None None None Never

  None (edit)
Description Jay Lee 2007-03-16 22:30:37 EDT
Description of problem:
X crashes on logout/restart when running x86_64 arch, i945 graphics and XD bit
capability is disabled

Version-Release number of selected component (if applicable):
kernel-2.6.18-8.1.1.el5.x86_64
xorg-x11-drv-i810-1.6.5-9.2.el5

How reproducible:
Always

Steps to Reproduce:
1.  System with x86_64 processor but "Execute Disable" feature is off in BIOS
(or no option to turn on in BIOS).  System is a Toshiba Satellite A105-S4334
with Core 2 Duo T5500.  XD feature is disabled and cannot be set in the BIOS.
2.  RHEL 5 x86_64 Desktop installed
3.  If system is booted with rhgb option then system will crash after rhgb exits
and gdm should be loading.  If rhgb is removed from grub.conf then user can
login but CTRL+ALT+Backspace will result in a crash.
  
Actual results:

System crashes when X is unloaded.

Expected results:
System should not crash.

Additional info:
I am relatively certain I am running against the bug described at:
https://bugs.freedesktop.org/show_bug.cgi?id=5085

I am testing the 1 liner patch from:
http://lkml.org/lkml/2006/10/18/68

and will report back on whether or not that fixed the issue once I get a custom
kernel compiled.
Comment 1 Jay Lee 2007-03-16 23:33:25 EDT
OK, I have recompiled 2.6.18-8.1.1.el5.x86_64 with the patch from:

http://lkml.org/lkml/2006/10/18/68

and can confirm that it fixes the problem.  I can now successfully boot with
rhgb and can exit/restart X without any crashes.

I also checked the vanilla 2.6.20.3 kernel and found that the one line patch has
been added to the official kernel.
Comment 2 Jay Lee 2007-07-30 19:01:01 EDT
It would be nice to see this in 5.1.  I know that many laptops and desktops
still ship with XD disabled by default and the solution is by no means obvious.

Jay
Comment 4 Jarod Wilson 2007-10-08 11:54:42 EDT
Unfortunately, this slipped through the cracks and missed the 5.1 deadline, but I'm getting it posted for 
review for 5.2 (shouldn't have a problem getting in).
Comment 5 Jarod Wilson 2007-10-26 09:54:40 EDT
During review, the question as to whether or not this is also a problem under a
xen kernel came up. I don't have any reproducing hardware of my own readily
available, so I was hoping perhaps you could verify whether or not this problem
also occurs if you're booted on a xen kernel. (Because xen is xen, we have to
patch yet another file to fix this if its a problem w/the xen kernel too).
Comment 6 Jay Lee 2007-10-29 10:28:44 EDT
  I have not had to deal with this bug in a while because Toshiba finally
enabled an XD setting in the BIOS of the A105 and I've upgraded to a newer
Toshiba laptop which has XD and VT.  However, I'd still recommend fixing this as
there are still machines out there w/o a BIOS option nor is it obvious that
turning on XD in the BIOS will resolve the issue.

  I borrowed back the A105 system and disabled XD in the BIOS, I found that
while I could reproduce the problem with the original x86-64 kernel for RHEL5
and the latest kernel from yum, I could not reproduce the problem using the
original RHEL5 xen kernel or the latest xen kernel from yum.  Note that I did
not test stability under Xen extensively though so I am not 100% sure it doesn't
have issues but I could CTRL+ALT+Backspace the X under the xen kernels and X
would restart unlike the non-xen kernels which would crash at that point.
Comment 7 RHEL Product and Program Management 2007-11-01 19:55:32 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 9 Don Zickus 2007-11-29 12:07:07 EST
in 2.6.18-58.el5
You can download this test kernel from http://people.redhat.com/dzickus/el5
Comment 11 Don Domingo 2008-02-07 00:07:11 EST
this bug has been tagged for inclusion in the RHEl5.2 release notes. please post
the necessary content for it. thanks!

Comment 12 Jarod Wilson 2008-02-18 15:34:29 EST
relnote content:

x86_64 systems with Intel graphics and XD (execute disable) protection disabled
no longer crash upon exiting an X session.
Comment 13 Don Domingo 2008-02-18 18:24:28 EST
thanks Jarod, adding to RHEL5.2 release notes under "Resolved Issues":

<quote>
(x86_64) Systems equipped with Intel graphics cards that have the XD (execute
disable) option disabled no longer crash upon exiting an X session.
</quote>

please advise if any further revisions are required.
Comment 14 Don Domingo 2008-04-01 22:14:44 EDT
Hi,
the RHEL5.2 release notes will be dropped to translation on April 15, 2008, at
which point no further additions or revisions will be entertained.

a mockup of the RHEL5.2 release notes can be viewed at the following link:
http://intranet.corp.redhat.com/ic/intranet/RHEL5u2relnotesmockup.html

please use the aforementioned link to verify if your bugzilla is already in the
release notes (if it needs to be). each item in the release notes contains a
link to its original bug; as such, you can search through the release notes by
bug number.

Cheers,
Don
Comment 16 errata-xmlrpc 2008-05-21 10:41:57 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0314.html

Note You need to log in before you can comment on or make changes to this bug.