Bug 232756 - selinux policy problem with ntpdate/ntpd and firstboot
selinux policy problem with ntpdate/ntpd and firstboot
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-17 04:28 EDT by G.Wolfe Woodbury
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-24 05:05:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
setroubleshooter alert (2.64 KB, text/plain)
2007-03-17 04:28 EDT, G.Wolfe Woodbury
no flags Details

  None (edit)
Description G.Wolfe Woodbury 2007-03-17 04:28:21 EDT
Description of problem:
  Setroubleshooter reports a problem with ntpdate doing a pipefs write in the
context of firstboot.  It requests that a bug report be filed.


Version-Release number of selected component (if applicable):
ntp-4.2.4p0-1.fc7
selinux-policy-targeted-2.5.8-5.fc7

How reproducible:
unknown


Steps to Reproduce:
1. rawhide install of 2007-03-16
2. configure ntp "sync before starting"
3.
  
Actual results:
AVC message:
avc: denied { write } for comm="ntpdate" dev=pipefs egid=0 euid=0
exe="/usr/sbin/ntpdate" exit=0 fsgid=0 fsuid=0 gid=0 items=0 name="[8959]"
path="pipe:[8959]" pid=2277 scontext=system_u:system_r:ntpd_t:s0 sgid=0
subj=system_u:system_r:ntpd_t:s0 suid=0 tclass=fifo_file
tcontext=system_u:system_r:firstboot_t:s0 tty=(none) uid=0

Expected results:


Additional info:
setroubleshooter alert attached
Comment 1 G.Wolfe Woodbury 2007-03-17 04:28:21 EDT
Created attachment 150299 [details]
setroubleshooter alert
Comment 2 Daniel Walsh 2007-03-20 10:48:13 EDT
Fixed in selinux-policy-2.5.9-1
Comment 3 G.Wolfe Woodbury 2007-03-22 07:26:01 EDT
seems to be gone, but will test more when I can get a rawhide install done later
today.
Comment 4 G.Wolfe Woodbury 2007-04-24 05:05:36 EDT
definitely gone.

Note You need to log in before you can comment on or make changes to this bug.