Bug 232776 - New windows appear in top left of screen, title bar above the gnome panel
New windows appear in top left of screen, title bar above the gnome panel
Status: CLOSED DUPLICATE of bug 230149
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-17 11:04 EDT by Dave Russell
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-28 17:47:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screen grab of the situation (141.98 KB, image/png)
2007-03-17 11:04 EDT, Dave Russell
no flags Details
output from lspci -vv (12.64 KB, text/plain)
2007-03-17 11:06 EDT, Dave Russell
no flags Details

  None (edit)
Description Dave Russell 2007-03-17 11:04:51 EDT
Description of problem:

When I enable desktop effects, it causes all my new windows to appear in the top
left of the screen as shown in the attached png image.

If I disable desktop effects, windows appear normally.

Version-Release number of selected component (if applicable):

compiz-0.3.6-2.fc6

This is a fully updated FC6 machine as of 17th March 2006

How reproducible:

Unsure, I have another laptop running FC6 with the radeon driver, and that
machine does not suffer from this.

My desktop machine is using the "intel" driver as shown in the excerpt below

Section "Device"
        Identifier  "Videocard0"
        Driver      "intel"
EndSection


Steps to Reproduce:
1. Install FC6 on similar hardware
2. Fully update it
3. Enable desktop effects
4. Watch awkward things happen when you open new applications
  
Actual results:
Windows open with their title bars at the 0.0 screen position.

Expected results:
Windows should open as and wherever they fit on the screen.

Additional info:
Comment 1 Dave Russell 2007-03-17 11:04:51 EDT
Created attachment 150309 [details]
Screen grab of the situation
Comment 2 Dave Russell 2007-03-17 11:06:04 EDT
Created attachment 150310 [details]
output from lspci -vv
Comment 3 Adam Huffman 2007-03-23 13:29:53 EDT
Yes, I've seen this on several machines, with Intel and Nvidia graphics hardware.

I've had to right-click on the application, select Move, move it with the cursor
keys then grab it with the mouse in order to place it properly.
Comment 4 Jeff Needle 2007-03-27 10:15:56 EDT
I ran into this with compiz-0.3.6-2.fc6 and Intel 945 and fixed it by adding the
"place" plugin.  To do this, fire up gconf-editor, go to
apps->compiz->general->allscreens->options and add place to active_plugins.
Comment 5 Kristian Høgsberg 2007-03-28 17:47:25 EDT

*** This bug has been marked as a duplicate of 230149 ***

Note You need to log in before you can comment on or make changes to this bug.