Bug 232783 - The ide-tape.ko module that I routinely compile for each kernel update does net recognise the tape device when loaded.
The ide-tape.ko module that I routinely compile for each kernel update does n...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-17 15:05 EDT by Kelly-Rand
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-18 13:39:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output from log/messages and list of previous modules compiled (853 bytes, text/plain)
2007-03-17 15:46 EDT, Kelly-Rand
no flags Details

  None (edit)
Description Kelly-Rand 2007-03-17 15:05:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.0.10) Gecko/20070313 Fedora/1.5.0.10-5.fc6 Firefox/1.5.0.10

Description of problem:
I have been using this tape drive for 5 Yrs. without problem. I do have to compile the ide-tape.ko module at every kernel update but that has never been a problem and I did the same for this update. The tape drive is a Seagate STT8000a atapi drive on ide1 typically identified as hdd on my system.
What I have noticed about the latest compiled module is that it is approximately 30Kbytes smaller than the last 4 modules that I have compiled.

Version-Release number of selected component (if applicable):
kernel-2.6.20-1.2925.fc6

How reproducible:
Always


Steps to Reproduce:
1. After kernel update download matching kernel source srpm. Execute the rpmbuild > kernel.spec command to build the patched source tree as normal user. CD to /ide directory where ide-tape.c is located and rename the existing Makefile to makefile.orig
2. Create Makefile per the release note instructions for compiling kernel modules for the running kernel. Issue the make command as normal user, review the output for error messages, none reported.
3. As root copy ide-tape.ko to /lib/modules/2.6.20-1.2925.fc6/kernel/drivers/ide/
4. Issue depmod -a, issue MAKEDEV -x ht0 nht0 or reboot for devices to be created
5. Issue mt -f /dev/nht0 status, in this case I get the following:
/dev/nht0: No such device or address


Actual Results:
/dev/nht0: No such device or address


Expected Results:
I should see the status output that shows what block is currently listed and some error check output for the device.

Additional info:
# less /var/log/dmesg | head
Linux version 2.6.20-1.2925.fc6 (brewbuilder@ls20-bc1-13.build.redhat.com) (gcc version 4.1.1 20070105 (Red Hat 4.1.1-51)) #1 SMP Sat Mar 10 18:38:39 EST 2007
Command line: ro root=LABEL=/12 iommu=noaperture rhgb quiet

I will post log and command output as an attachment.
Comment 1 Kelly-Rand 2007-03-17 15:46:18 EDT
Created attachment 150319 [details]
Output from log/messages and list of previous modules compiled
Comment 2 Kelly-Rand 2007-03-17 15:51:42 EDT
I have listed the severity as normal, but for me I cannot upgrade to this kernel
till the problem is resolved. I cannot access or create backups without the
ide-tape module working.
Comment 3 Jon Masters 2007-03-17 16:35:38 EDT
Do you have the tape module correctly loaded, and is the device node in /dev
there? (it'll be managed by udev so mknoding it won't make much difference on a
reboot).

There are better ways of building modules than *in* the kernel tree - you can
build the module separately and overwrite the original if really needed. But,
why do you need to build your own tape module, anyway? :-)

Jon.
Comment 4 Kelly-Rand 2007-03-17 19:40:59 EDT
(In reply to comment #3)
> Do you have the tape module correctly loaded, and is the device node in /dev
> there? (it'll be managed by udev so mknoding it won't make much difference on a
> reboot).
> 
> There are better ways of building modules than *in* the kernel tree - you can
> build the module separately and overwrite the original if really needed.

I do use short cuts in compiling, I grabbed from a couple different source trees
and compiled one at a time inserting each in lib/modules as described
above,overwriting each in turn, but I don't know what you mean by "in the kernel
tree" other than I could compile in the user directory some folder. The kernel
tree is a good filing system that keeps me familiar with the structure.

> why do you need to build your own tape module, anyway? :-)

I need to compile ide-tape because it is not compiled by default being
considered "expiremental" by the maintainers. I've used it for ten years so it
baffles me that it is considered as such. Ide-scsi needs a separate cable
because it shares the same cable as the cd. I don't care to install a separate
controller and have another piece of hardware to maintain. 
Now, what output would be helpful in diagnosing this?

Jim K-R
Comment 5 Kelly-Rand 2007-03-18 10:06:50 EDT
Please table this bug report.

I have just discovered that there is a hardware problem with the drive that
occured just prior to the latest kernel update.

My apologies

Jim K-R
Comment 6 Pete Zaitcev 2007-03-18 13:39:44 EDT
We still need to look at what happens to tape devices now that
IDE subsystem is gone. In theory, they should be picked by st
automatically with libata... or do they?
Comment 7 Kelly-Rand 2007-03-18 15:58:28 EDT
That worries me scripts for all the ide devices. 

Jim K-R
Comment 8 Kelly-Rand 2007-03-26 21:19:36 EDT
See bug 234106
I have found that the hardware still works in Fc5.

Note You need to log in before you can comment on or make changes to this bug.