Bug 232796 - fedora's firefox incorrectly renders svg
fedora's firefox incorrectly renders svg
Product: Fedora
Classification: Fedora
Component: cairo (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
Depends On:
  Show dependency treegraph
Reported: 2007-03-17 18:45 EDT by Adam Pribyl
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-07-30 05:54:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
rendering in Epiphany 2.16.3-3.fc6 (91.14 KB, image/png)
2007-03-17 18:50 EDT, Matěj Cepl
no flags Details

  None (edit)
Description Adam Pribyl 2007-03-17 18:45:07 EDT
Description of problem:
When displaying svg in firefox from default fedora installation the svg image is
garbled. Check e.g.:

Version-Release number of selected component (if applicable):

How reproducible:

Expected results:
Check the firefox downloaded from mozilla.com pages.

Additional info:
Could be related to cairo?!
Comment 1 Matěj Cepl 2007-03-17 18:50:46 EDT
Created attachment 150321 [details]
rendering in Epiphany 2.16.3-3.fc6

Just to add one data-point -- this is rendering in epiphany on FC6. Looks
garbled to me as well.
Comment 2 Adam Pribyl 2007-03-18 17:51:09 EDT
Definitely. But epiphany is also using gecko - I'll bet on some library behind.
Comment 5 Martin Stransky 2007-03-26 07:35:46 EDT
Hm, all our gecko apps look broken.
Comment 6 Martin Stransky 2007-03-26 09:22:22 EDT
Looks like a problem with system cairo library. When firefox is built with
"--disable-system-cairo", svg rendering works fine. Reassigning.
Comment 7 Martin Stransky 2007-03-26 09:23:08 EDT
btw. broken in rawhide, too.
Comment 8 Adam Pribyl 2007-05-23 06:59:42 EDT
Still present in latest rawhide liveCD image for F7.
Comment 9 Sylvain Pasche 2007-05-24 18:47:52 EDT
Launchpad bug (also affecting Ubuntu):

Comment 10 Sylvain Pasche 2007-07-30 05:51:39 EDT
This is fixed in version
Comment 11 Martin Stransky 2007-07-30 05:54:05 EDT
aha, thanks for the notice.

Note You need to log in before you can comment on or make changes to this bug.