Bug 23295 - validate input
validate input
Status: CLOSED WONTFIX
Product: eCos
Classification: Retired
Component: GDB stubs (Show other bugs)
CVS
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: ecc-bugs-int
ecc-bugs-int
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-04 08:56 EST by Jesper Skov
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-10 01:43:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jesper Skov 2001-01-04 08:56:41 EST
Stubs should check that the user is not trying to load application on
top of the piece of RAM reserved for the stubs.
Comment 1 George Thomas 2001-09-10 01:43:11 EDT
I'm not sure that the generic stub can really do this, certainly not
easily as the load process is just GDB sending some memory write commands.

RedBoot does try to accomplish this though.
Comment 2 Jesper Skov 2001-09-10 08:43:32 EDT
I opened this as a Bug mostly because I didn't want to muck anymore with the
stubs code until we know what code to use in the future. The actual fix is
fairly simple, I think; __write_mem_safe() should simply fail if attempts are
made at writing between some magic limits (.text start and .bss end or something
close to that).

Must be careful to allow (interactive) writes to various tables though.


Of course, the goal here would be to prevent users getting stuck and ask
silly questions when they try to download ROM apps, or RAM apps on top of
a RAM RedBoot. Dunno if it happens so often that it's worth protecting for
though (just give 'em the rope)... Nah, I'm closing the bug.

Note You need to log in before you can comment on or make changes to this bug.