Bug 23298 - Tests should autoadjust
Summary: Tests should autoadjust
Status: CLOSED WONTFIX
Alias: None
Product: eCos
Classification: Retired
Component: Kernel   
(Show other bugs)
Version: CVS
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: ecc-bugs-int
QA Contact: ecc-bugs-int
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-04 14:13 UTC by Jesper Skov
Modified: 2007-04-18 16:30 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-20 15:46:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jesper Skov 2001-01-04 14:13:16 UTC
Some of the kernel tests are hardwired to do certain number of loops
for various targets. Would be nice if this could be automated somehow,
since we'll be spending more and more time hacking tests in various
ways to get them running on new faster/slower targets.

In particular the dhrystone test can be changed to increase the number
of loops to get reliable data on faster targets.

Reducing loops may be harder to deal with - but a generic way to handle
it would be something like:

 max_loops = HARDWIRED_LIMIT_GOOD_FOR_MOST_TARGETS;
 start_time = <get time>;
 adjusted = 0;
 while (loops < max_loops) {
   if (!adjusted && loops > (max_loops / 20)) {
      now = <get time>;
      if (now - start_time > 1 second)
         max_loops = (max_loops / (now - start_time));
      adjusted = 1;
   }
   ...test loop body...
 }

Comment 1 Alex Schuilenburg 2003-06-20 15:46:44 UTC
This bug has moved to http://bugs.ecos.sourceware.org/show_bug.cgi?id>23298


Note You need to log in before you can comment on or make changes to this bug.