Bug 2330 - gated and loopback interface conspire to break broadcasts, workaround included
gated and loopback interface conspire to break broadcasts, workaround included
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: initscripts (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-04-22 17:51 EDT by darrell
Modified: 2014-03-16 22:09 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-09-20 15:13:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description darrell 1999-04-22 17:51:07 EDT
when you run gated, it removes the network route to
127.0.0.0/8, and replaces it with a host route for 127.0.0.1
pointing to lo.  It also makes 127.0.0.0/8 a martian,
which means all routes to that net are ignored.

Consequently, after gated starts, anytime a program tries to
make a network broadcast, (i.e. talk to 127.255.255.255
amongst others) it gets a network unreachable and fails --
ypbind or rup for example.

gated doesn't allow you to config around this particular
behavior --it's hardcoded in. however, you can change the
loopback broadcast to not be 127.255.255.255 and things will
start working again

We've been using 255.255.255.255 for weeks with no problems.

(I've put this bug under the initscripts, since that's
where the workaround would go, and I can't select two
categories)
Comment 1 Cristian Gafton 1999-07-28 19:08:59 EDT
This could be correct; I have seen on other systems that the broadcast
for lo is not set to 127.255.255.255

assigned to notting
Comment 2 Bill Nottingham 1999-09-20 15:13:59 EDT
This is something we probably won't change in the initscripts,
but will be something that the user will have to configure
if they need to.

Note You need to log in before you can comment on or make changes to this bug.