Bug 233001 - CVE-2007-1003 xserver XC-MISC integer overflow
CVE-2007-1003 xserver XC-MISC integer overflow
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11-server (Show other bugs)
5.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Søren Sandmann Pedersen
impact=important,reported=20070216,em...
: Security
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-19 16:18 EDT by Josh Bressers
Modified: 2014-06-18 05:09 EDT (History)
2 users (show)

See Also:
Fixed In Version: RHSA-2007-0127
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-03 14:43:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josh Bressers 2007-03-19 16:18:06 EDT
+++ This bug was initially created as a clone of Bug #233000 +++

Sean Larsson, iDefense Labs, discovered an integer overflow flaw in the XC-MISC
extension.  This overflow could allow a local user to gain root privileges.

-- Additional comment from bressers@redhat.com on 2007-03-19 16:10 EST --
Created an attachment (id=150431)
Poposed upstream patch
Comment 3 Josh Bressers 2007-04-03 12:47:27 EDT
Lifting embargo
Comment 4 Red Hat Bugzilla 2007-04-03 14:43:55 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHSA-2007-0127.html

Note You need to log in before you can comment on or make changes to this bug.