Bug 23301 - Add stub breakpoints
Add stub breakpoints
Status: CLOSED WONTFIX
Product: eCos
Classification: Retired
Component: Debugging (Show other bugs)
CVS
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: ecc-bugs-int
ecc-bugs-int
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-04 09:18 EST by Jesper Skov
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-20 11:46:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jesper Skov 2001-01-04 09:18:43 EST
Letting the stub handle breakpoints will reduce the time GDB spends
on putting data back and forth between each step somewhat. Not entirely
though, since it keeps setting/clearing breakpoints - it just gets a bit
more effecient.

I raised the subject (on gdb-local) of letting the stub handle the
breakpoints entirely and not set/clear them continously, but this appears
to be a feature, allowing GDB to crash / lose the connection without
affecting the target state. Of course, this is only true if it happens
while the user is interacting with GDB - not while GDB is waiting for
target actions... Oh well...
Comment 1 Alex Schuilenburg 2003-06-20 11:46:57 EDT
This bug has moved to http://bugs.ecos.sourceware.org/show_bug.cgi?id>23301

Note You need to log in before you can comment on or make changes to this bug.