Bug 233066 - Installation via FTP/HHTP in local network - NIC not working
Summary: Installation via FTP/HHTP in local network - NIC not working
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: libdhcp   
(Show other bugs)
Version: 5.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: David Cantrell
QA Contact: Alexander Todorov
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 5.4, TechnicalNotes
TreeView+ depends on / blocked
 
Reported: 2007-03-20 10:59 UTC by Harald Wegscheider
Modified: 2010-03-14 21:28 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
libdhcp did not allow for some situations where a static network configuration was specified. Specifically, when a configuration without a DHCP server was specified during installation, the network interface was not activated. This would preclude installations through FTP and HTTP. Libdhcp now activates the interface when a static configuration is specified, even when no DHCP server is present so that network-based installations are possible.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 10:55:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
libdhcp-1.20-static-iface-config.patch (656 bytes, patch)
2007-05-14 20:24 UTC, David Cantrell
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:1333 normal SHIPPED_LIVE libdhcp bug fix update 2009-09-01 10:39:17 UTC

Description Harald Wegscheider 2007-03-20 10:59:30 UTC
Description of problem:
When installing via FTP/HTTP in a local network ( without gateway ) the network
interface is not activated. The given IPaddress is not shown via ifconfig.

Workaround: switch to virtual console 2 and activate interface via 
'ifconfig ethx IP MASK up'. --> not practicable when installing virtual machine,
as switching to virtual console seems to be difficult/not working.


How reproducible:
Always

Steps to Reproduce:
1.  boot from CD using ' linux askmethod' , install from FTP or HTTP
2.  activate network interface, provide manual IP, no gateway
3.  switch to virtual console 2 ( CTRL+ALT+F2 ), type 'ifconfig'
  
Actual results:
no IP address for interface eth0 ( IPv4)

Expected results:
IP Address

Comment 1 David Cantrell 2007-05-14 20:22:45 UTC
Flagging for RHEL-5.2

Comment 2 David Cantrell 2007-05-14 20:24:02 UTC
Created attachment 154683 [details]
libdhcp-1.20-static-iface-config.patch

Comment 3 RHEL Product and Program Management 2007-12-03 20:41:44 UTC
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release.  This request will
be reviewed for a future Red Hat Enterprise Linux release.

Comment 6 David Cantrell 2009-02-21 02:25:33 UTC
Fixed in libdhcp-1.20-7.el5 and later releases.

Comment 8 Alexander Todorov 2009-05-11 13:18:56 UTC
VERIFIED with anaconda-11.1.2.172-1 / libdhcp-1.20-9.el5

Configured eth0 to use address from the local network and no gateway. Stage2 was loaded successfully, ifconfig showed the correct address on tty2 and the install was able to complete.

Comment 10 Ruediger Landmann 2009-08-18 05:01:52 UTC
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
libdhcp did not allow for some situations where a static network configuration was specified. Specifically, when a configuration without a DHCP server was specified during installation, the network interface was not activated. This would preclude installations through FTP and HTTP. Libdhcp now activates the interface when a static configuration is specified, even when no DHCP server is present so that network-based installations are possible.

Comment 11 errata-xmlrpc 2009-09-02 10:55:56 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1333.html


Note You need to log in before you can comment on or make changes to this bug.