Bug 233067 - rhn_register exit with Invalid ORG_ID requested
rhn_register exit with Invalid ORG_ID requested
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rhn-client-tools (Show other bugs)
5.0
i686 Linux
urgent Severity urgent
: ---
: ---
Assigned To: Jesus M. Rodriguez
Preethi Thomas
:
Depends On: 229785
Blocks: 227613
  Show dependency treegraph
 
Reported: 2007-03-20 07:15 EDT by Nicolas GRENECHE
Modified: 2010-10-22 09:50 EDT (History)
8 users (show)

See Also:
Fixed In Version: RHBA-2007-0591
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 12:57:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas GRENECHE 2007-03-20 07:15:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.0.10) Gecko/20070216 Firefox/1.5.0.10

Description of problem:
We were running RHEL 4 ES. We have a valid RHN suscription. I downloaded RHEL 5 to install it. I made a fresh install not an update. Install is ok, it works. I had troubles with rhn_register.

I made this operations :

1) Login to my RHN web space.
2) Download ISOs of RHEL 5.
3) Get this two numbers for my server :
- installation number from redhat site for RHEL 5 (hope this number is ok !).
- my rhn registration number.
4) Broke filesystem of my server.
5) Install RHEL 5 (no X, quite minimal install).
6) Delete the two old systems profiles related to RHEL 4 on my rhn web space.
7) Try to register the serveur via 'rhn_register' on freshly installed server with login/password that I use for accessing my rhn web space --> Error

Here are the details of this error :

1) Errors on screen :
--
Error Class Code: 42
Error Class Info: Invalid ORG_ID requested
Explanation: 
     An error has occurred while processing your request. If this problem
     persists please enter a bug report at bugzilla.redhat.com.
     If you choose to submit the bug report, please be sure to include
     details of what you were trying to do when this error occurred and
     details on how to reproduce this problem.
--

2) From /var/log/up2date
--
Traceback (most recent call last):
  File "/usr/sbin/rhn_register", line 79, in ?
    app.run()
  File "/usr/share/rhn/up2date_client/rhncli.py", line 65, in run
    sys.exit(self.main() or 0)
  File "/usr/sbin/rhn_register", line 64, in main
    ui.main()
  File "/usr/share/rhn/up2date_client/tui.py", line 1834, in main
    tui.run()
  File "/usr/share/rhn/up2date_client/tui.py", line 1673, in run
    self.other['org_id'])
  File "/usr/share/rhn/up2date_client/rhnreg.py", line 682, in activateRegistrationNumber
    result = server.registration.activate_registration_number(username, password, registrationNumber, other)
  File "/usr/share/rhn/up2date_client/rhnserver.py", line 52, in __call__
    raise self.__exception_from_fault(f)
up2date_client.up2dateErrors.CommunicationError: Erreur de communication avec le serveur. Le message était :

Error Class Code: 42
Error Class Info: Invalid ORG_ID requested
Explanation: 
     An error has occurred while processing your request. If this problem
     persists please enter a bug report at bugzilla.redhat.com.
     If you choose to submit the bug report, please be sure to include
     details of what you were trying to do when this error occurred and
     details on how to reproduce this problem.
--


Version-Release number of selected component (if applicable):
rhn-setup-0.4.13-1.el5

How reproducible:
Always


Steps to Reproduce:
1. Run 'rhn_register --nox'
2. Enter login / password from my redhat account
3. Validate

Actual Results:
Error Class Code: 42
Error Class Info: Invalid ORG_ID requested
Explanation: 
     An error has occurred while processing your request. If this problem
     persists please enter a bug report at bugzilla.redhat.com.
     If you choose to submit the bug report, please be sure to include
     details of what you were trying to do when this error occurred and
     details on how to reproduce this problem.

Expected Results:
It would have asked me if I was willing to send my software and hardware features to redhat no ?

Additional info:
[root@biosoil ~]# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 5 (Tikanga)

[root@biosoil ~]# rpm -q yum
yum-3.0.1-5.el5

[root@biosoil ~]# rpm -q rhn-setup
rhn-setup-0.4.13-1.el5

[root@biosoil ~]# rhn_register --version
rhn_register (Outils client de Red Hat Network) 0.4.13-1.el5
Copyright (C) 1999-2006 Red Hat, Inc.
Sous les termes de la licence GPL.
Comment 9 Nicolas GRENECHE 2007-03-26 09:00:58 EDT
I've tried to register via 'rhn_register' with X11 + Gnome enabled and then it
works ! It also works with 'rhnreg_ks --profilename my_server --username foo
--password bar --subscription my_rhn_sub_number'.

With same login / pass it doesn't work with 'rhn_register' in text mode.
Comment 10 James Bowes 2007-03-26 10:17:52 EDT
(In reply to comment #8)
> This is NOT true, it doesn't always return an empty list.  See the attachment
> #150494 [edit] which has the correct information.

What environment was this against? From what I've been told, this data isn't
populated at all in prod.

Comment 11 Nicolas GRENECHE 2007-03-26 10:30:23 EDT
What do you mean with environment ? Installed packages, architecture etc.
Comment 12 James Bowes 2007-03-26 10:39:12 EDT
(In reply to comment #11)
> What do you mean with environment ? Installed packages, architecture etc.

Hi,

Sorry, that was in reply to another comment
Comment 13 shrek-m 2007-03-28 05:33:35 EDT
thanks
`rhnreg_ks --username=<rhn_account> --password=<passwd>
works here after the same problem.

clean fresh rhel5-server german inst, no X, minimal install

# rhn_register
--> /var/log/up2date

Traceback (most recent call last):
  File "/usr/sbin/rhn_register", line 79, in ?
    app.run()
  File "/usr/share/rhn/up2date_client/rhncli.py", line 65, in run
    sys.exit(self.main() or 0)
  File "/usr/sbin/rhn_register", line 64, in main
    ui.main()
  File "/usr/share/rhn/up2date_client/tui.py", line 1834, in main
    tui.run()
  File "/usr/share/rhn/up2date_client/tui.py", line 1745, in run
    result = win.run()
  File "/usr/share/rhn/up2date_client/tui.py", line 469, in run
    self.passwordEntry.value())
  File "/usr/share/rhn/up2date_client/tui.py", line 66, in tui_call_wrapper
    results = func(*params)
  File "/usr/share/rhn/up2date_client/rhnreg.py", line 807, in getPossibleOrgs
    cachedOrgs.setDefaultOrg(orgsFromServer['default_org'])
  File "/usr/share/rhn/up2date_client/rhnreg.py", line 764, in setDefaultOrg
    raise InvalidDefaultError("Tried to set default org to %s. Valid "
up2date_client.rhnreg.InvalidDefaultError: Tried to set default org to 5374115.
Valid values are []
Comment 14 Nicolas GRENECHE 2007-03-28 06:04:16 EDT
Reading shrek-m I noticed that I forgot to tell that I was trying to install a
FRENCH RHEL 5 ES, no X, minimal install.
Comment 18 arnaud 2007-04-27 04:46:57 EDT
I got the same kind of error after installing RHEL5.

The installation is done without any problems.

But when i want to register on rhn, it stacks.

I did it as follow :

1. Run 'rhn_register --nox'
2. Enter login and password from my redhat account
3. Validate

In /var/log/up2date :

Traceback (most recent call last):
  File "/usr/sbin/rhn_register", line 79, in ?
    app.run()
  File "/usr/share/rhn/up2date_client/rhncli.py", line 65, in run
    sys.exit(self.main() or 0)
  File "/usr/sbin/rhn_register", line 64, in main
    ui.main()
  File "/usr/share/rhn/up2date_client/tui.py", line 1834, in main
    tui.run()
  File "/usr/share/rhn/up2date_client/tui.py", line 1745, in run
    result = win.run()
  File "/usr/share/rhn/up2date_client/tui.py", line 469, in run
    self.passwordEntry.value())
  File "/usr/share/rhn/up2date_client/tui.py", line 66, in tui_call_wrapper
    results = func(*params)
  File "/usr/share/rhn/up2date_client/rhnreg.py", line 807, in getPossibleOrgs
    cachedOrgs.setDefaultOrg(orgsFromServer['default_org'])
  File "/usr/share/rhn/up2date_client/rhnreg.py", line 764, in setDefaultOrg
    raise InvalidDefaultError("Tried to set default org to %s. Valid "
up2date_client.rhnreg.InvalidDefaultError: Tried to set default org to 5392549.
Valid values are []


But when I used rhnreg_ks, the registration is done. 

Anyone has an idea of this problem ?

Thank you.

Comment 22 Arenas Belon, Carlo Marcelo 2007-05-29 14:22:26 EDT
i was able to reproduce this same problem also in RHEL 4.5 and in RHEL 5 Client
(which needs all the rhn tools and dependencies installed manually from the CD)

to reproduce just install with all options (including base) disabled after going
into "customize package".

this is most likely because of a missing dependency, as the same
account/installation works if going by default with all selected packages as
suggested by the installer
Comment 29 James Slagle 2007-07-17 16:19:40 EDT
updated the errata bug list to include this bug.
Comment 30 Preethi Thomas 2007-07-30 09:36:40 EDT
Fails_qa
I did not get any failures for the test plan in comment#26. But here is a used
case that failed.

1. rhn_register tui
2. On the login screen use and existing user/password.
3. Click next.
4. Click back on this screen.
5. enter a different login and click next.
Observe the error.

[root@rlx-3-08 ~]# rhn_register
An error has occurred:

Error Class Code: 42
Error Class Info: Invalid ORG_ID requested
Explanation: 
     An error has occurred while processing your request. If this problem
     persists please enter a bug report at bugzilla.redhat.com.
     If you choose to submit the bug report, please be sure to include
     details of what you were trying to do when this error occurred and
     details on how to reproduce this problem.

See /var/log/up2date for more information
Comment 32 Preethi Thomas 2007-08-16 14:27:53 EDT
making it verified as per comment #31
Comment 33 Bob Wilson 2007-10-15 18:21:00 EDT
An error has occurred:                                                         
                                                        
 
Error Class Code: 42
Error Class Info: Invalid ORG_ID requested
Explanation: 
     An error has occurred while processing your request. If this problem
     persists please enter a bug report at bugzilla.redhat.com.
     If you choose to submit the bug report, please be sure to include
     details of what you were trying to do when this error occurred and
     details on how to reproduce this problem.
 
See /var/log/up2date for more information
[root@MAFsniffer rhn]# 
Comment 35 errata-xmlrpc 2007-11-07 12:57:14 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0591.html

Note You need to log in before you can comment on or make changes to this bug.