Bug 233113 - Build on ppc fails
Build on ppc fails
Product: Fedora
Classification: Fedora
Component: gnubg (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jon Ciesla
Fedora Extras Quality Assurance
Depends On: 233143
Blocks: FE7Target
  Show dependency treegraph
Reported: 2007-03-20 11:10 EDT by Michael Schwendt
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-05-08 09:29:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2007-03-20 11:10:26 EDT
Fedora 5 package is newer than Fedora 6 package.
Fedora 5 package is newer than Fedora 7 package.
But build of package in CVS fails on ppc.
Could also be a bug in gnuplot for ppc.

limb AT jcomserv.net:
      FE5 > FE6 (0:20061119-8.fc5.2 > 0:20061119-7.fc6)
      FE5 > FE7 (0:20061119-8.fc5.2 > 0:20061119-7.fc7)


	  for f in gnubg.info gnubg.info-[0-9] gnubg.info-[0-9][0-9] gnubg.i[0-9]
gnubg.i[0-9][0-9]; do \
	    if test -f $f; then mv $f $backupdir; restore=mv; else :; fi; \
	  done; \
	else :; fi && \
	cd "$am__cwd"; \
	if /bin/sh /builddir/build/BUILD/gnubg/missing --run makeinfo   -I . \
	 -o gnubg.info gnubg.texi; \
	then \
	  rc=0; \
	  cd .; \
	else \
	  rc=$?; \
	  cd . && \
	  $restore $backupdir/* `echo "./gnubg.info" | sed 's|[^/]*$||'`; \
	fi; \
	rm -rf $backupdir; exit $rc
if [ -n "gnuplot" ]; then \
	gnuplot annealing.gp && \
	tr -d '\f' < anneal.txt > ./annealing.txt; fi
/bin/sh: line 2:   400 Segmentation fault      gnuplot annealing.gp
make[2]: *** [annealing.eps] Error 139
make[2]: Leaving directory `/builddir/build/BUILD/gnubg/doc'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/builddir/build/BUILD/gnubg'
make: *** [all] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.79732 (%build)
Comment 1 David Woodhouse 2007-03-20 12:13:53 EDT
It builds for me on FC6. Rawhide dies thus:

RPM build errors:
    user dwmw2 does not exist - using root
    group dwmw2 does not exist - using root
    user dwmw2 does not exist - using root
    group dwmw2 does not exist - using root
    user dwmw2 does not exist - using root
    group dwmw2 does not exist - using root
    user dwmw2 does not exist - using root
    group dwmw2 does not exist - using root
    user dwmw2 does not exist - using root
    group dwmw2 does not exist - using root
    File not found: /var/tmp/gnubg-20061119-8-root-root/usr/share/gnubg/textures.txt
    File not found: /var/tmp/gnubg-20061119-8-root-root/usr/share/gnubg/textures
Comment 2 Jon Ciesla 2007-03-20 12:23:58 EDT
It builds fine for me in FC-6 also, but dies that way (#1) in mock.  I've not
made any changes since this was released.  It must be something gnubg depends on
causing this, since in installed releases, the textures files are present.

I'll go through the source and see what I can find, my mock log doesn't look
promising so far. . .
Comment 4 Jon Ciesla 2007-03-20 12:54:29 EDT
That definately looks like a gnuplot bug.  I'll file it.  

Now, I still need to figure out the textures issue.
Comment 5 David Woodhouse 2007-03-20 13:05:16 EDT
Comment 6 Jon Ciesla 2007-03-20 13:09:03 EDT
(In reply to comment #5)
> http://david.woodhou.se/gnubg-build.log

How did you manage this? Any changes from vanilla patched devel?
Comment 7 David Woodhouse 2007-03-20 13:28:50 EDT
It's not quite up to date rawhide. I made the SRPM from CVS, then tried
'rpmbuild --target ppc --rebuild ...'. And watched it fail.
Comment 8 Jon Ciesla 2007-03-20 13:32:18 EDT
So you're cross-compiling?  Michael, is your host native ppc?
Comment 9 David Woodhouse 2007-03-20 13:46:26 EDT
Not crosscompiling. It's a native build on ppc64 (Actually an IBM pSeries POWER5
machine). Fairly similar to the machine in the build system, I think.
Comment 10 Jon Ciesla 2007-03-20 13:53:57 EDT
IOC.  I've nearly got a version done to correct the textures issue.  I'll get it
into CVS and see where the gnuplot bug leads.
Comment 11 Michael Schwendt 2007-03-20 14:02:07 EDT
ppc2.fedora.redhat.com is native powerpc, yes.


Build for FC-6 succeeded:
Comment 12 Jon Ciesla 2007-03-20 14:48:22 EDT
Committed new fix for textures, but I still get the gnuplot failure.
Comment 13 Jon Ciesla 2007-04-04 14:56:23 EDT
Still fails on devel, succeeds on FC6.  SAme for all arches.  Updated gnuplot bug.
Comment 14 Jon Ciesla 2007-04-17 08:31:10 EDT
Updated FC6 local build with gnuplot-4.0.0-18.fc7.i386.rpm installed works.

Since today is the Freeze, I'll resume testing after release, I suppose.
Comment 15 Jon Ciesla 2007-05-08 09:29:18 EDT
Built on all archs, closing.  In communication with rel-eng.

Note You need to log in before you can comment on or make changes to this bug.