Bug 233122 - mount_autofs_indirect: failed to read map
mount_autofs_indirect: failed to read map
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: autofs (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Moyer
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-20 11:33 EDT by Stephane HUGARIE
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-20 13:05:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephane HUGARIE 2007-03-20 11:33:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; fr-FR; rv:1.8.1) Gecko/20061010 Firefox/2.0

Description of problem:
My NIS Master is on FC2
My Client is on FC6 ressently updated

When I start autofs service we can see on /var/log/messages :
Mar 20 15:26:19 cofra32 automount[2077]: Starting automounter version 5.0.1-0.rc3.26, master map auto.master
Mar 20 15:26:19 cofra32 automount[2077]: using kernel protocol version 5.00
Mar 20 15:26:19 cofra32 automount[2077]: read_file_source_instance: file map /etc/auto.ref not found
Mar 20 15:26:19 cofra32 automount[2077]: mount_autofs_indirect: failed to read map for /comptes_ref
Mar 20 15:26:19 cofra32 automount[2077]: handle_mounts: mount of /comptes_ref failed!
Mar 20 15:26:19 cofra32 automount[2077]: master_do_mount: failed to startup mount
Mar 20 15:26:19 cofra32 automount[2077]: read_file_source_instance: file map /etc/auto.projets not found
Mar 20 15:26:19 cofra32 automount[2077]: mount_autofs_indirect: failed to read map for /projets
Mar 20 15:26:19 cofra32 automount[2077]: handle_mounts: mount of /projets failed!
Mar 20 15:26:19 cofra32 automount[2077]: master_do_mount: failed to startup mount
Mar 20 15:26:19 cofra32 automount[2077]: read_file_source_instance: file map /etc/auto.web not found
Mar 20 15:26:19 cofra32 automount[2077]: mount_autofs_indirect: failed to read map for /web
Mar 20 15:26:19 cofra32 automount[2077]: handle_mounts: mount of /web failed!
Mar 20 15:26:19 cofra32 automount[2077]: master_do_mount: failed to startup mount
Mar 20 15:26:19 cofra32 automount[2077]: read_file_source_instance: file map /etc/auto.home not found
Mar 20 15:26:19 cofra32 automount[2077]: mount_autofs_indirect: failed to read map for /home/u
Mar 20 15:26:19 cofra32 automount[2077]: handle_mounts: mount of /home/u failed!
Mar 20 15:26:19 cofra32 automount[2077]: master_do_mount: failed to startup mount
Mar 20 15:26:19 cofra32 automount[2077]: master_read_master: no mounts in table


It's work on FC2 to FC5
And it's work when I tried to mount manualy the volume 

Version-Release number of selected component (if applicable):
autofs-5.0.1-0.rc3.26

How reproducible:
Always


Steps to Reproduce:
1.The client (FC6) is Nis client of FC2 server
2.start autofs service
3.

Actual Results:
The automount does'nt access to expoted volume

Expected Results:
The automount created /home/u mount point

Additional info:
Comment 1 Jeff Moyer 2007-03-20 11:36:54 EDT
Could you post your maps, please?  If using ypcat to get the contents, please
specify the '-k' option.  Please also post the results from the following command:

grep "automount" /etc/nsswitch.conf
Comment 2 Stephane HUGARIE 2007-03-20 11:59:32 EDT
From FC6 client:
----------------

# ypcat -k auto.master
/comptes_ref /etc/auto.ref
/projets /etc/auto.projets
/web /etc/auto.web
/home/u /etc/auto.home

# ypcat -k auto.ref
refcom elodie:/exports/vol0001/comptes_ref/refcom
rfsyncml elodie:/exports/vol0001/comptes_ref/rfsyncml
refmfm elodie:/exports/vol0001/comptes_ref/refmfm
refl1ti elodie:/exports/vol0001/comptes_ref/refl1ti
.../...

# ypcat -k auto.projets
rao delphine:/exports/vol0002/projets/rao
adminsys2 elodie:/exports/vol0001/projets/adminsys2
adminsys delphine:/exports/vol0002/projets/adminsys
.../...

# ypcat -k auto.home
lelong delphine:/exports/vol0002/homes/lelong
toureau delphine:/exports/vol0002/homes/toureau
didier delphine:/exports/vol0002/homes/didier
.../...

and finally :
# grep "automount" /etc/nsswitch.conf
automount:  files nis
Comment 3 Jeff Moyer 2007-03-20 12:03:54 EDT
Your yp auto.master lists:
  /home/u /etc/auto.home

And you posted the yp map auto.home.  If the path is given explicitly like this,
then nsswitch.conf is not consulted for the location of the map.  That line
should read:
  /home/u auto.home

Things should work once you've fixed your map.
Comment 4 Stephane HUGARIE 2007-03-20 12:28:24 EDT
Yes, it's work now
thank you very much.

that is curious it is that that functioned in old the version of FC
(FC2 to FC5)
Comment 5 Jeff Moyer 2007-03-20 13:05:59 EDT
Yes, it is curious that it worked before.

Note You need to log in before you can comment on or make changes to this bug.