This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 233126 - adding usb headset causes sound module to not load at next boot
adding usb headset causes sound module to not load at next boot
Status: CLOSED DUPLICATE of bug 232217
Product: Fedora
Classification: Fedora
Component: system-config-soundcard (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-20 11:55 EDT by John Poelstra
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-22 07:10:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
before adding usb headset (43.59 KB, image/png)
2007-03-20 11:55 EDT, John Poelstra
no flags Details
after adding usb headset (43.29 KB, image/png)
2007-03-20 11:55 EDT, John Poelstra
no flags Details
after reboot usb headset still plugged in (42.14 KB, image/png)
2007-03-20 11:56 EDT, John Poelstra
no flags Details
two sound cards (57.65 KB, text/plain)
2007-03-20 13:33 EDT, John Poelstra
no flags Details
add usb headset (58.27 KB, text/plain)
2007-03-20 13:34 EDT, John Poelstra
no flags Details
after reboot usb headset still plugged in (60.19 KB, text/plain)
2007-03-20 13:35 EDT, John Poelstra
no flags Details

  None (edit)
Description John Poelstra 2007-03-20 11:55:05 EDT
Description of problem:

I have a box with two sound cards.  When I plug in a USB headset (Logitech 350)
I get a third sound device... everything is happy.

If I reboot my box with the USB headset still plugged in when the system comes
up one of my soundcards is missing.

I am attaching screen shots illustrating the problem.

Version-Release number of selected component (if applicable):
I'm not sure what package is really at fault so I'm taking some guesses...

# rpm -qa | egrep 'kudzu|hal|udev|kernel'
hal-0.5.8.1-6.fc6
kernel-headers-2.6.19-1.2911.6.5.fc6
kernel-2.6.19-1.2911.6.5.fc6
kernel-2.6.18-1.2798.fc6
kernel-devel-2.6.18-1.2798.fc6
kudzu-devel-1.2.57.6-1
kernel-devel-2.6.19-1.2911.6.5.fc6
udev-095-17.fc6
hal-devel-0.5.8.1-6.fc6
kudzu-1.2.57.6-1
hal-cups-utils-0.6.5-1.fc6

How reproducible:
100%

Steps to Reproduce:
1. Add USB headset-- look at system-config-soundcard and note 3 sound devices
2. Reboot box
3. look at system-config-soundcard and note 2 sound devices... there should be three
Comment 1 John Poelstra 2007-03-20 11:55:07 EDT
Created attachment 150500 [details]
before adding usb headset
Comment 2 John Poelstra 2007-03-20 11:55:45 EDT
Created attachment 150501 [details]
after adding usb headset
Comment 3 John Poelstra 2007-03-20 11:56:50 EDT
Created attachment 150502 [details]
after reboot usb headset still plugged in
Comment 4 Martin Stransky 2007-03-20 12:50:50 EDT
please attach /root/scsconfig.log, it can be generated by s-c-s
Comment 5 John Poelstra 2007-03-20 13:33:04 EDT
Created attachment 150511 [details]
two sound cards
Comment 6 John Poelstra 2007-03-20 13:34:01 EDT
Created attachment 150512 [details]
add usb headset
Comment 7 John Poelstra 2007-03-20 13:35:57 EDT
Created attachment 150513 [details]
after reboot usb headset still plugged in
Comment 8 Martin Stransky 2007-03-22 06:57:00 EDT
As a workaround you can add these lines to /etc/modprobe.conf

alias snd-card-2 snd-usb-audio
options snd-usb-audio index=2
Comment 9 Martin Stransky 2007-03-22 07:10:02 EDT

*** This bug has been marked as a duplicate of 232217 ***

Note You need to log in before you can comment on or make changes to this bug.