Bug 233376 - Add layer2 support to installer
Add layer2 support to installer
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.0
s390x Linux
high Severity high
: ---
: ---
Assigned To: David Cantrell
: FutureFeature, OtherQA
: 184669 245588 (view as bug list)
Depends On: 248049
Blocks: 201595 222082 228022
  Show dependency treegraph
 
Reported: 2007-03-21 17:52 EDT by Brad Hinson
Modified: 2010-03-14 17:32 EDT (History)
5 users (show)

See Also:
Fixed In Version: RHBA-2007-0644
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 12:21:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch to set layer2 mode if LAYER2=1 is defined (507 bytes, patch)
2007-03-21 17:52 EDT, Brad Hinson
no flags Details | Diff
Better patch, adds prompt in interactive mode (762 bytes, patch)
2007-03-22 18:56 EDT, Brad Hinson
no flags Details | Diff
Test initrd based on RHEL 5 GA (11.71 MB, application/octet-stream)
2007-03-29 14:39 EDT, Brad Hinson
no flags Details
Full support for layer2/layer3 (4.02 KB, patch)
2007-04-09 13:00 EDT, Brad Hinson
no flags Details | Diff
Test files based on RHEL 5.0 (12.05 MB, application/x-bzip2)
2007-04-09 13:06 EDT, Brad Hinson
no flags Details

  None (edit)
Description Brad Hinson 2007-03-21 17:52:29 EDT
Description of problem:
The following patch adds layer2 support to Anaconda

Version-Release number of selected component (if applicable):
RHEL 5.0

How reproducible:
Define layer2 VSWITCH, couple NIC

Actual results:
qeth hardware error when brought online

Additional info:
Requires LAYER2=1 to be added to CONF file
Comment 1 Brad Hinson 2007-03-21 17:52:29 EDT
Created attachment 150630 [details]
Patch to set layer2 mode if LAYER2=1 is defined
Comment 2 RHEL Product and Program Management 2007-03-22 10:18:12 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 3 Brad Hinson 2007-03-22 18:56:31 EDT
Created attachment 150706 [details]
Better patch, adds prompt in interactive mode
Comment 4 Brad Hinson 2007-03-29 14:39:25 EDT
Created attachment 151218 [details]
Test initrd based on RHEL 5 GA
Comment 5 John Jarvis 2007-04-05 15:51:37 EDT
*** Bug 184669 has been marked as a duplicate of this bug. ***
Comment 6 Brad Hinson 2007-04-09 13:00:36 EDT
Created attachment 152002 [details]
Full support for layer2/layer3

- Support for LAYER2=0 or LAYER2=1 in CONF file
- Support for interactive LPAR install
- Corresponding option added to initscript automatically
  -- ARP=no for layer 3
  -- OPTIONS="layer2=1" for layer 2
Comment 7 Brad Hinson 2007-04-09 13:06:38 EDT
Created attachment 152004 [details]
Test files based on RHEL 5.0

To test, untar to root of install tree.  File contains:
images/initrd.img     : updated initrd
RHupdates/network.py  : updated python script
Comment 10 John Jarvis 2007-05-01 16:12:04 EDT
This enhancement request was evaluated by the full Red Hat Enterprise Linux team
for inclusion in a Red Hat Enterprise Linux minor release.   As a result of this
evaluation, Red Hat has tentatively approved inclusion of this feature in the
next Red Hat Enterprise Linux Update minor release.   While it is a goal to
include this enhancement in the next minor release of Red Hat Enterprise Linux,
the enhancement is not yet committed for inclusion in the next minor release
pending the next phase of actual code integration and successful Red Hat and
partner testing.
Comment 12 Brad Hinson 2007-06-26 15:14:58 EDT
For release note:
---

The following applies to the s390x architecture only.  Anaconda now supports
connections to a VSWITCH, GuestLAN or OSA in layer 2 mode.  The installer will
now prompt for the mode in the initial stage of the installation.  The value
provided for the mode also affects the resulting network interface startup
script after installation.  For layer 2 installations, the value
OPTIONS="layer2=1" is written to ifcfg-eth0; for layer 3, the value ARP=no is
written.

Please note that when installing under z/VM, you can add either LAYER2=0 or
LAYER2=1 to the CMS CONF file to avoid being prompted for the mode each time. 
Use LAYER2=0 when the OSA is in layer 3 mode, and LAYER2=1 when the OSA is in
layer 2 mode.
Comment 13 Don Domingo 2007-06-26 20:44:27 EDT
adding to Release Notes (appearing after Beta):

<quote>
(s390x) Anaconda now supports connections to a VSWITCH, GuestLAN, or OSA in
layer 2 mode. The installer will now prompt for the mode in the initial stage of
the installation. The value provided for the mode also affects the resulting
network interface startup script after installation.

For layer 2 installations, the value OPTIONS="layer2=1" is written to
ifcfg-eth0; for layer 3, the value ARP=no is written.

Note that when installing on a Series z machine or guest, you can add either
LAYER2=0 or LAYER2=1 to the CMS CONF file to avoid being prompted for the mode
each time. Use LAYER2=0 when the OSA is in layer 3 mode, and LAYER2=1 when the
OSA is in layer 2 mode.
</quote>

please advise if any revisions are necessary. thanks!

Comment 18 Brad Hinson 2007-06-28 13:17:43 EDT
*** Bug 245588 has been marked as a duplicate of this bug. ***
Comment 21 Brad Hinson 2007-08-13 15:55:51 EDT
Based on bug 248049, can we edit the last paragraph to say this:
---

Note that when installing on a System z guest, you can add either LAYER2=0 or
LAYER2=1 to the CMS CONF file to avoid being prompted for the mode each time.
Use LAYER2=0 when the OSA is in layer 3 mode, and LAYER2=1 when the
OSA is in layer 2 mode.

When specifying LAYER2=1, you can also specify VSWITCH=1 when connecting to a
VSWITCH, or VSWITCH=0 when attaching the OSA directly.  When a VSWITCH is not in
use, you must specify the MAC address, or specify this in the CMS CONF file
beginning with MACADDR=.  When using a VSWITCH, this value is not necessary as
it is provided automatically.
Comment 22 Don Domingo 2007-08-14 01:18:44 EDT
thanks Brad, edited the note as follows:

<quote>
    Note that when installing on a System z guest, you can make the mode
persistent. To do so, add either LAYER2=0 or LAYER2=1 to the CMS CONF file. Use
LAYER2=0 when the OSA is in layer 3 mode, and LAYER2=1 when the OSA is in layer
2 mode.

    When specifying LAYER2=1, you can also specify VSWITCH=1 when connecting to
a VSWITCH, or VSWITCH=0 when connecting directly to the OSA. If a VSWITCH is not
in use, specify the MAC address in the CMS CONF file using the parameter
MACADDR=<MAC address>.
</quote>

please advise if any further revisions are required. note that the release notes
deadline is on 16 August (Thursday), at which point it'll be locked and dropped
for Translation. thanks!
Comment 23 Brad Hinson 2007-08-14 14:42:42 EDT
Update:

This release note change is dependent on bug 248049 getting approved (waiting on
PM).  Looking into that now (before Thursday deadline).
Comment 24 John Poelstra 2007-08-14 19:51:56 EDT
A fix for this issue has been included in the packages contained in the beta
(RHN channel) or most recent snapshot (partners.redhat.com) for RHEL5.1.  Please
verify that your issue is fixed.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If you cannot access bugzilla, please reply with a message to Issue Tracker and
I will change the status for you.

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to ASSIGNED.
Comment 25 Don Domingo 2007-08-17 01:39:31 EDT
Brad, revising the release note to change "CMS CONF" to "CMS configuration
file". FYI
Comment 26 John Poelstra 2007-08-24 01:19:11 EDT
A fix for this issue should have been included in the packages contained in the
most recent snapshot (partners.redhat.com) for RHEL5.1.  

Requested action: Please verify that your issue is fixed as soon as possible to
ensure that it is included in this update release.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to FAILS_QA.

More assistance: If you cannot access bugzilla, please reply with a message to
Issue Tracker and I will change the status for you.  If you need assistance
accessing ftp://partners.redhat.com, please contact your Partner Manager.
Comment 27 John Poelstra 2007-08-30 20:26:44 EDT
A fix for this issue should have been included in the packages contained in the
RHEL5.1-Snapshot4 on partners.redhat.com.  

Requested action: Please verify that your issue is fixed *as soon as possible*
to ensure that it is included in this update release.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to FAILS_QA.

If you cannot access bugzilla, please reply with a message to Issue Tracker and
I will change the status for you.  If you need assistance accessing
ftp://partners.redhat.com, please contact your Partner Manager.
Comment 28 John Poelstra 2007-09-11 15:23:40 EDT
A fix for this issue should have been included in the packages contained in the
RHEL5.1-Snapshot6 on partners.redhat.com.  

Requested action: Please verify that your issue is fixed ASAP to confirm that it
will be included in this update release.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to FAILS_QA.

If you cannot access bugzilla, please reply with a message to Issue Tracker and
I will change the status for you.  If you need assistance accessing
ftp://partners.redhat.com, please contact your Partner Manager.
Comment 29 John Poelstra 2007-09-20 00:48:18 EDT
A fix for this issue should have been included in the packages contained in the
RHEL5.1-Snapshot7 on partners.redhat.com.  

Requested action: Please verify that your issue is fixed ASAP to confirm that it
will be included in this update release.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to FAILS_QA.

If you cannot access bugzilla, please reply with a message to Issue Tracker and
I will change the status for you.  If you need assistance accessing
ftp://partners.redhat.com, please contact your Partner Manager.
Comment 31 James Laska 2007-09-21 12:34:19 EDT
IBM: Can you confirm that the reported defect is no longer present in snapshot#7?
Comment 32 John Poelstra 2007-09-26 19:45:40 EDT
A fix for this issue should be included in the packages contained in
RHEL5.1-Snapshot8--available now on partners.redhat.com.  

IMPORTANT: This is the last opportunity to confirm that your issue is fixed in
the RHEL5.1 update release.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to FAILS_QA.

If you cannot access bugzilla, please reply with a message to Issue Tracker and
I will change the status for you.  If you need assistance accessing
ftp://partners.redhat.com, please contact your Partner Manager.
Comment 33 Georg Markgraf 2007-10-15 11:15:16 EDT
The layer 2 support got verified on IBM site.
For details please refer to:
LTC 21811 - RIT88406- FEAT:200121: update s390 init scripts to support OSA 
layer 2 and CDLC NICs
Seems this is the Anaconda part for that. If so then its als overified OK
Comment 35 errata-xmlrpc 2007-11-07 12:21:02 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0644.html

Note You need to log in before you can comment on or make changes to this bug.