Bug 233383 - fvwm crashing on launch of X session
fvwm crashing on launch of X session
Product: Fedora
Classification: Fedora
Component: fvwm (Show other bugs)
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Goode
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-03-21 18:55 EDT by Mark Palmeri
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-04-01 21:21:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Mark Palmeri 2007-03-21 18:55:46 EDT
Description of problem:
I installed fvwm-2.5.21-4.fc6.x86_64.rpm, and when I tried to launch my session
from the login screen, I get an error that the session lasted less than 10
seconds, and it quits, returning my to my login prompt.  dmesg has the following
> Mar 21 17:42:11 kitsuma Installed: fvwm.x86_64 2.5.21-4.fc6
> Mar 21 17:42:33 kitsuma kernel: fvwm2[6454]: segfault at 00007fffec2e93d8
> rip 0000000000425cb3 rsp 00007fffe74800a0 error 4
> Mar 21 17:44:42 kitsuma kernel: fvwm2[2709]: segfault at 00007fffb8b62e88
> rip 0000000000425cb3 rsp 00007fffb3cf9b50 error 4
> Mar 21 17:45:59 kitsuma Erased: fvwm

Manual install of fvwm 2.4.20 from a tarred source works fine.

Version-Release number of selected component (if applicable):

How reproducible:
Everytime I tried to launch X

Steps to Reproduce:
1. Install fvwm rpm from the Fedora extras repo.
2. Log in via X GUI startup
Actual results:
Error - session < 10 sec - quits back to login screen.

Expected results:
Successful launch of fvwm.

Additional info:
Comment 1 Adam Goode 2007-03-22 21:07:49 EDT

Thank you for the bug report. Without a stack trace from the crash it is 
very hard to determine what caused the crash. Please see
http://fedoraproject.org/wiki/StackTraces for more information about
getting a useful stack trace.

Specifically, you'll need to install fvwm and fvwm-debuginfo. This yum command
should work:

yum --enablerepo=extras-debuginfo install fvwm-debuginfo fvwm

Once that's done, try starting X using the "failsafe session". Once the xterm
appears, try running fvwm using gdb as given here:

If it crashes again, please grab the stacktrace and append it to this bug.

Comment 2 Mark Palmeri 2007-04-01 21:21:00 EDT
This turns out to not be a "bug" with the software, but was caused by having
depreciated values in the fvwm2rc config file (that worked in 2.4.20) that
prevented the Xsession from launching.  The 'MenuStyle', 'FvmwButtons', and
'wmconfig' syntax were the culprits.

Note You need to log in before you can comment on or make changes to this bug.