Bug 233391 - yum miscalculates disk requirements when disk space is low
yum miscalculates disk requirements when disk space is low
Status: CLOSED DUPLICATE of bug 235892
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-21 20:31 EDT by Kwan Lowe
Modified: 2014-01-21 17:57 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-10 13:34:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
full output from yum update (17.66 KB, text/plain)
2007-03-21 20:31 EDT, Kwan Lowe
no flags Details
custom package, incase it matters. (2.68 KB, application/x-rpm)
2007-07-03 09:49 EDT, David Timms
no flags Details

  None (edit)
Description Kwan Lowe 2007-03-21 20:31:39 EDT
Description of problem:
yum miscalculates disk requirements when disk space is low:
[snip]
Transaction Summary
=============================================================================
Install      0 Package(s)
Update      52 Package(s)
Remove       0 Package(s)

Total download size: 76 M
[snip]

Error Summary
-------------
Disk Requirements:
  At least 5732MB needed on the /usr filesystem.

[root] xm-fc7-001 ~]# df -h
Filesystem            Size  Used Avail Use% Mounted on
[snip]
/dev/mapper/rootvg-usr_lv
                      1.9G  1.7G  119M  94% /usr


Version-Release number of selected component (if applicable):
yum-3.1.4-1.fc7

How reproducible:
Run "yum update" with less space than required for updates.


Steps to Reproduce:
1. Run yum update with less space than needed for proper installation

Actual results:
yum reports that Disk Requirements are close to 6Gig whereas the proper number
is about 50M extra needed.

Expected results:

yum disk space number should be correct
Additional info:

Possibly related to bug id=209980
Comment 1 Kwan Lowe 2007-03-21 20:31:39 EDT
Created attachment 150636 [details]
full output from yum update
Comment 2 Jeff Johnson 2007-03-23 13:45:07 EDT
The problem is in in the wording of the problem.

The term "needs" is in the sense that "... needs an additional ..."

All other packages will report the same problem for a given mount point.

WONTFIX
Comment 3 Kwan Lowe 2007-03-23 14:07:56 EDT
I'm not certain I understand... The /usr filesystem had 1.9G total, with 1.7G
used. There were 76M of updates. Yum is asking for 5732M (close to 6G) needed.
That's almost 4G more than needed.
Comment 4 Jeff Johnson 2007-03-23 14:41:33 EDT
I don't know where you are getting 5732M from.

What is being indicated is

1) You have 119Mb on /usr:
/dev/mapper/rootvg-usr_lv
                      1.9G  1.7G  119M  94% /usr

2) You need an *additional* 182MB on /usr in order to run the transaction.

Transaction Check Error:
  installing package glibc-common-2.5.90-19 needs 182MB on the /usr filesystem

Comment 5 Kwan Lowe 2007-03-23 14:49:54 EDT
The 5732M is what the error is.  This number was reported by yum:

Error Summary
-------------
Disk Requirements:
  At least 5732MB needed on the /usr filesystem.

Comment 6 Jeff Johnson 2007-03-26 08:31:08 EDT
Then this is a yum error. The correct answer is that an additional 182M is needed on /usr.

Please reassign this bug to yum.
Comment 7 Matthew Miller 2007-04-10 12:34:27 EDT
Fedora 7 test bugs should be filed against "devel", not against test1/2/3. This
isn't obvious, I know. Moving this report so it isn't lost.

This is a bulk message -- I apologize if this was actually meant to be targeted
against a different release. If so, please fix or let me know. Thanks.
Comment 8 Kwan Lowe 2007-04-10 13:34:39 EDT
Closing, moving to devel #235892:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=235892

*** This bug has been marked as a duplicate of 235892 ***
Comment 9 David Timms 2007-07-03 09:49:02 EDT
Created attachment 158440 [details]
custom package, incase it matters.

Present on Fedora 7.
Another more extreme example:
# df -h
Filesystem	      Size  Used Avail Use% Mounted on
/dev/mapper/VolGroup00-LogVolslash
		      7.8G  7.1G  313M	96% /

# yum localinstall /usr/src/redhat/RPMS/i386/timms-global-0.0.2-5.i386.rpm
--nogpgcheck
{own package that only has requires, no content}
...
Install     89 Package(s)	  
Update	     1 Package(s)	  
Remove	     0 Package(s)	  

Total download size: 697 M
{note: downloads and yum cache are on a different partition}
Is this ok [y/N]: y
Downloading Packages:
Running Transaction Test
Finished Transaction Test

Transaction Check Error:
  installing package torcs-data-tracks-road-1.3.0-1 needs 104MB on the /
filesystem
...
  installing package ppracer-0.3.1-10.fc7 needs 1085MB on the / filesystem
  installing package bitstream-vera-fonts-1.10-7 needs 1085MB on the /
filesystem

Error Summary
-------------
Disk Requirements:
  At least 57250MB needed on the / filesystem.
{ 57.25 GB ! to install ~1.5 GB of data.}

Note You need to log in before you can comment on or make changes to this bug.