Bug 233406 - azureus throws exception instead of down/up loading
azureus throws exception instead of down/up loading
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: azureus (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Anthony Green
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-22 02:44 EDT by Gábor
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-11 16:39:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gábor 2007-03-22 02:44:41 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); hu; rv:1.8.1.2) Gecko/20070312 Firefox/2.0.0.2

Description of problem:
when i starrt azureus it can connecet to tracker (at least it seems to do so) but it can not connect to peers (nor seeders neither leachers).

Version-Release number of selected component (if applicable):
azureus-2.5.0.0-11.fc7

How reproducible:
Always


Steps to Reproduce:
1.start azureus
2.try to download anything
3.

Actual Results:
nothing

Expected Results:
download begins

Additional info:
DEBUG::Thu Mar 22 07:36:22 GMT+01:00 2007::com.aelitis.azureus.core.networkmanager.impl.tcp.ConnectDisconnectManager::addNewOutboundRequests::-1:
  ConnectDisconnectManager::address exception: full=/80.98.47.30:9342, hostname=80.98.47.30, port=9342, unresolved=false, full_sub=/80.98.47.30, host_address=80.98.47.30
 channel=gnu.java.nio.SocketChannelImpl@33bec405, socket=gnu.java.nio.NIOSocket@32b7947d [unconnected], local_address=0.0.0.0/0.0.0.0, local_port=-1, remote_address=<null>, remote_port=0
    ConnectDisconnectManager::mainLoop::-1,ConnectDisconnectManager::access$2::-1,ConnectDisconnectManager$2::runSupport::-1,AEThread::run::-1
java.net.SocketException: Socket closed
   at gnu.java.net.PlainSocketImpl.setOption(libgcj.so.8rh)
   at java.net.Socket.setSoTimeout(libgcj.so.8rh)
   at gnu.java.nio.SocketChannelImpl.implConfigureBlocking(libgcj.so.8rh)
   at java.nio.channels.spi.AbstractSelectableChannel.configureBlocking(libgcj.so.8rh)
   at com.aelitis.azureus.core.networkmanager.impl.tcp.ConnectDisconnectManager.addNewRequest(Azureus2.jar.so)
   at com.aelitis.azureus.core.networkmanager.impl.tcp.ConnectDisconnectManager.addNewOutboundRequests(Azureus2.jar.so)
   at com.aelitis.azureus.core.networkmanager.impl.tcp.ConnectDisconnectManager.mainLoop(Azureus2.jar.so)
   at com.aelitis.azureus.core.networkmanager.impl.tcp.ConnectDisconnectManager.access$2(Azureus2.jar.so)
   at com.aelitis.azureus.core.networkmanager.impl.tcp.ConnectDisconnectManager$2.runSupport(Azureus2.jar.so)
   at org.gudy.azureus2.core3.util.AEThread.run(Azureus2.jar.so)
Comment 1 Anthony Green 2007-03-29 17:00:55 EDT
I just upgraded to 2.5.0.4 and this error seems to have gone away.  2.5.0.4
should show up in Extras in a few days.
Comment 2 Gábor 2007-03-30 14:43:08 EDT
(In reply to comment #1)
> I just upgraded to 2.5.0.4 and this error seems to have gone away.  2.5.0.4
> should show up in Extras in a few days.

Me too (Source RPM: azureus-2.5.0.4-2.fc7.src.rpm). But unfortunately the bug 
is still here. 

(i have two interface one for the locale net and one for the internet with
public ip. can it cause the error?)

The azureus version i downloaded from sourceforge works fine.
Comment 3 Tom Tromey 2007-03-30 18:41:15 EDT
I'm seeing this too and I have a reduced test case.
The bug seems to be a simple oversight in libgcj's
SocketChannelImpl.

import java.nio.channels.*;
import java.net.*;

public class Q {
  public static void main(String[] args) throws Throwable {
    SocketChannel sc = SocketChannel.open();
    sc.socket().setReceiveBufferSize(4096);
    sc.socket().setSendBufferSize(4096);
    sc.socket().setReuseAddress(true);
    sc.socket().bind(new InetSocketAddress(9095));
    sc.configureBlocking(false);
  }
}
Comment 4 Tom Tromey 2007-04-02 18:16:50 EDT
I've checked in a fix for this to GCC trunk.
I also put it on the RH 4.1 branch.
I'm not sure when this will end up in Rawhide, but I assume
relatively soon.  It is r123441 on the branch.
Comment 5 Gábor 2007-04-05 13:13:53 EDT
(In reply to comment #4)
> I've checked in a fix for this to GCC trunk.
> I also put it on the RH 4.1 branch.
> I'm not sure when this will end up in Rawhide, but I assume
> relatively soon.  It is r123441 on the branch.

yum updated the libgcj package today, so i checked it again.
(gcc-4.1.2-8.src.rpm)

Azureus still dont downloading, the exception is changed to this:


DEBUG::Thu Apr 05 19:02:41 GMT+02:00
2007::com.aelitis.azureus.core.networkmanager.impl.tcp.VirtualBlockingServerChannelSelector::accept_loop::-1:
    VirtualBlockingServerChannelSelector$1::runSupport::-1,AEThread::run::-1
java.lang.NullPointerException
   at gnu.java.nio.ServerSocketChannelImpl.accept(libgcj.so.8rh)
   at
com.aelitis.azureus.core.networkmanager.impl.tcp.VirtualBlockingServerChannelSelector.accept_loop(Azureus2.jar.so)
   at
com.aelitis.azureus.core.networkmanager.impl.tcp.VirtualBlockingServerChannelSelector$1.runSupport(Azureus2.jar.so)
   at org.gudy.azureus2.core3.util.AEThread.run(Azureus2.jar.so)
DEBUG::Thu Apr 05 19:02:42 GMT+02:00
2007::com.aelitis.azureus.core.versioncheck.VersionCheckClient::preProcessReply::-1:
  com.aelitis.azureus.core.networkmanager.admin.NetworkAdminException: DNS query
failed
   at
com.aelitis.azureus.core.networkmanager.admin.impl.NetworkAdminASNLookupImpl.lookupDNS(Azureus2.jar.so)
   at
com.aelitis.azureus.core.networkmanager.admin.impl.NetworkAdminASNLookupImpl.lookupDNS(Azureus2.jar.so)
   at
com.aelitis.azureus.core.networkmanager.admin.impl.NetworkAdminASNLookupImpl.<init>(Azureus2.jar.so)
   at
com.aelitis.azureus.core.networkmanager.admin.impl.NetworkAdminImpl.lookupASN(Azureus2.jar.so)
   at
com.aelitis.azureus.core.versioncheck.VersionCheckClient.preProcessReply(Azureus2.jar.so)
   at
com.aelitis.azureus.core.versioncheck.VersionCheckClient.executeHTTP(Azureus2.jar.so)
   at
com.aelitis.azureus.core.versioncheck.VersionCheckClient.performVersionCheck(Azureus2.jar.so)
   at
com.aelitis.azureus.core.versioncheck.VersionCheckClient.getVersionCheckInfoSupport(Azureus2.jar.so)
   at
com.aelitis.azureus.core.versioncheck.VersionCheckClient.getExternalIpAddress(Azureus2.jar.so)
   at
com.aelitis.azureus.core.instancemanager.impl.AZMyInstanceImpl.readExternalAddress(Azureus2.jar.so)
   at
com.aelitis.azureus.core.instancemanager.impl.AZMyInstanceImpl.getExternalAddress(Azureus2.jar.so)
   at
com.aelitis.azureus.core.instancemanager.impl.AZInstanceImpl.encode(Azureus2.jar.so)
   at
com.aelitis.azureus.core.instancemanager.impl.AZInstanceManagerImpl.sendMessage(Azureus2.jar.so)
   at
com.aelitis.azureus.core.instancemanager.impl.AZInstanceManagerImpl.sendMessage(Azureus2.jar.so)
   at
com.aelitis.azureus.core.instancemanager.impl.AZInstanceManagerImpl$request.<init>(Azureus2.jar.so)
   at
com.aelitis.azureus.core.instancemanager.impl.AZInstanceManagerImpl.sendRequest(Azureus2.jar.so)
   at
com.aelitis.azureus.core.instancemanager.impl.AZInstanceManagerImpl.search(Azureus2.jar.so)
   at
com.aelitis.azureus.core.instancemanager.impl.AZInstanceManagerImpl$4.runSupport(Azureus2.jar.so)
   at org.gudy.azureus2.core3.util.AEThread.run(Azureus2.jar.so)
Caused by: javax.naming.NoInitialContextException: Can't load
InitialContextFactory class: com.sun.jndi.dns.DnsContextFactory caused by
java.lang.ClassNotFoundException: com.sun.jndi.dns.DnsContextFactory not found
in
gnu.gcj.runtime.SystemClassLoader{urls=[file:/usr/lib64/eclipse/swt-gtk-3.2.jar,file:/usr/share/java/bcprov.jar,file:/usr/share/java/jakarta-commons-cli.jar,file:/usr/share/java/log4j.jar,file:/usr/share/java/gtk2.8.jar,file:/usr/share/java/glib0.2.jar,file:/usr/share/azureus/Azureus2.jar],
parent=gnu.gcj.runtime.ExtensionClassLoader{urls=[], parent=null}}
   at javax.naming.spi.NamingManager.getInitialContext(libgcj.so.8rh)
   at javax.naming.InitialContext.getDefaultInitCtx(libgcj.so.8rh)
   at javax.naming.InitialContext.getURLOrDefaultInitCtx(libgcj.so.8rh)
   at
javax.naming.directory.InitialDirContext.getURLOrDefaultInitDirCtx(libgcj.so.8rh)
   at javax.naming.directory.InitialDirContext.getAttributes(libgcj.so.8rh)
   at
com.aelitis.azureus.core.networkmanager.admin.impl.NetworkAdminASNLookupImpl.lookupDNS(Azureus2.jar.so)
   ...18 more
Comment 6 Anthony Green 2007-11-11 16:39:13 EST
I'm WONTFIXing this.  Please run azureus with IcedTea.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.