Bug 233458 - RHEL5 - GAIM 2.0 fails using http proxy (unlike firefox and yum which work fine)
RHEL5 - GAIM 2.0 fails using http proxy (unlike firefox and yum which work fine)
Status: CLOSED DUPLICATE of bug 208126
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gaim (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Warren Togami
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-22 11:36 EDT by Don Hoover
Modified: 2007-11-30 17:07 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-22 13:08:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Don Hoover 2007-03-22 11:36:04 EDT
+++ This bug was initially created as a clone of Bug #208126 +++

Description of problem:

gaim accounts (yahoo, aim, jabber, msn) all fail to properly use http_proxy

Version-Release number of selected component (if applicable):

gaim-2.0.0-0.11.beta3.fc6

How reproducible:

always

1) can say 'Use Global Proxy Settings' - but there is no place to set GAIM
global proxy settings... so i tried the gnome System -> Preferences -> Network
Proxy ... and used the same automatic proxy url i use for firefox - and that failed.

2) i tried to use 'environmental settings' expecting it to work with
http_proxy=http://<host>:<port> and that not only failed but reverted to 'no
proxy' the next time i went to modify the account proxy setting.

3) i tried to enter the <host> <port> explicitly for each account.

Steps to Reproduce:
1. use gaim behind a http proxy / firewall
2.
3.
  
Actual results:

using explicit "http" host and port settings i see:

msn - connection error from Notification server: writing error
yahoo - unable to read
jabber - Proxy connection error 502 
aim - Proxy connection error 502

Expected results:

these to work. as the native clients do on windows with the http proxy

Additional info:

-- Additional comment from thekingant@users.sourceforge.net on 2006-09-26 12:21
EST --
I think I've fixed in this in our Subversion repo already, and it should be
fixed in beta 4 when it's released.  But please let me know if you still have
problems using that version.

-- Additional comment from das_deniz@yahoo.com on 2006-09-29 11:14 EST --
i've downloaded gaim from svn thrusday sep 28 ~8pm EDT
built it and installed it (./configure prefix=/opt/gaim)
i rpm -e gaim to make sure the old one is gone and ran
/opt/gaim/bin/gaim... cannot use http proxy with this for

yahoo, aim, or jabber/gtalk, HOWEVER MSN WORKS !!! 

so there is some progress. please allow me to test any fixes
you add to svn - but i can only update in the evenings as the
svn http proxy support does not work for me either :(

-- Additional comment from thekingant@users.sourceforge.net on 2006-09-29 12:26
EST --
What proxy server are you using?  Do you get an error message when you try to
use Yahoo, AIM, and Jabber/GTalk?  What does it say?  Can you open the debug
window and try to sign on and attach the last 20 lines or so (feel free to edit
out any screen names, etc.)?

-- Additional comment from thekingant@users.sourceforge.net on 2006-09-29 12:31
EST --
I find myself wondering if your proxy server is configured to not allow the type
of traffic needed to proxy the other protocols.  Does HTTPS work through your
proxy?  The easiest way to get stuff working in squid is to comment out the line
http_access deny CONNECT !SSL_ports

Or you could try adding 5190 to the list of SSL_ports.

-- Additional comment from das_deniz@yahoo.com on 2006-09-29 15:28 EST --
right - i'll try to get debug information.

keep in mind that the proxy server works for http and https with firefox, with
http for yum, and with https for svn (proxy info in the global, *not* group1,
server section duh.)...

sweet, i was able to checkout a new version of gaim at work - now i'll go build
it and get you some debug info.

-- Additional comment from das_deniz@yahoo.com on 2006-09-29 16:45 EST --
so from the packet traces i obtained it looks like https proxy support is
screwing up for aim and jabber (note also that when i try to use the old 5223
port instead of 5222 in the jabber settings it still uses 5222)

jabber:

proxy: Attempting connection to TODO
proxy: Connecting to talk.google.com:5222 via proxyserver.enterasys.com:80 using
HTTP
proxy: Connection in progress
proxy: Connected.
proxy: Using CONNECT tunneling for talk.google.com:5222
proxy: Proxy server replied with:
HTTP/1.1 502 Proxy Error ( The specified Secure Sockets Layer (SSL) port is not
allowed. ISA Server is not configured to allow SSL requests from this port. Most
Web browsers use port 443 for SSL requests.  )

AIM:

proxy: Attempting connection to TODO
proxy: Connecting to login.oscar.aol.com:5190 via proxyserver.enterasys.com:80
using HTTP
proxy: Connection in progress
proxy: Connected.
proxy: Using CONNECT tunneling for login.oscar.aol.com:5190
proxy: Proxy server replied with:
HTTP/1.1 502 Proxy Error ( The specified Secure Sockets Layer (SSL) port is not
allowed. ISA Server is not configured to allow SSL requests from this port. Most
Web browsers use port 443 for SSL requests.  )


but for yahoo it behaves as if the proxy is fine - but the http packet flow just
stops.

proxy: Attempting connection to TODO
proxy: Connecting to scs.msg.yahoo.com:80 via proxyserver.enterasys.com:80 using
HTTP
proxy: Connection in progress
proxy: HTTP proxy connection established

and eventually this account connection times out.

-- Additional comment from stu@nosnilmot.com on 2006-09-29 16:52 EST --
This is mostly a problem with the configuration of your proxy blocking the sorts
of connections Gaim needs to make to use it (most IM protocols are not actually
http based, so need to be tunnelled over 'CONNECT' with http proxies)

For AIM you should be able to change the port to 443 in the advanced tab of
account options. This may also work for Google Talk too.

I forget what the problem with yahoo and http proxies is, that may in fact be a
bug in Gaim.

-- Additional comment from das_deniz@yahoo.com on 2006-09-29 17:43 EST --
excellent. AIM with 443 instead of 5190 works.
jabber and yahoo do not work with this tweak however....
i did talk to our proxy admin and they claim they've 
locked down the other 'ssl' ports to prevent 'tunneling' - yawn.

if you have any lights go off about yahoo i'd be happy to hear about it.

-- Additional comment from andrew.benham@thus.net on 2006-12-01 08:27 EST --
There's something new in Gaim which doesn't work as I'd expect, having upgraded
a home machine from FC5 to FC6.

My GNOME Network Proxy setting is to use automatic proxy configuration (i.e.
a proxy.pac file).  This is a JavaScript file, loaded with a file:// URI.

Gaim doesn't like this at all, and refuses to talk to any of the IM servers
having thrown an error for each account.

I don't need any proxies for IM (the proxy.pac file is there to allow me to
tunnel  requests for work URIs which are not globally visable).  Fortunately I
can change the "proxy type" for each account in Gaim to "none", but I didn't
have to do this before.

-- Additional comment from donhoover@ups.com on 2007-03-22 11:34 EST --
The proxy support in the new GAIM 2.0 in RHEL5 is BROKEN BIG TIME....  I run
GAIM 1.5 on the same box, it works FINE, fire up the RHEL5 2.0 version and it
gets proxy errors and seems really really broken.


RedHat should have stayed with the current production version of GAIM
1.5.x....GAIM 2.0 is not even out yet.
Comment 1 Warren Togami 2007-03-22 13:08:55 EDT
Please provide more details for this issue in the original Bug #233458.  It
doesn't help to have a cloned bug here.

*** This bug has been marked as a duplicate of 208126 ***

Note You need to log in before you can comment on or make changes to this bug.