Bug 2335 - Adding default route fails if not on same network as IF
Adding default route fails if not on same network as IF
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
5.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-04-23 00:50 EDT by tm
Modified: 2014-03-16 22:09 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-09-20 16:33:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description tm 1999-04-23 00:50:40 EDT
Have a computer which eth0 address is on a different
subnet than the router providing the default gw.

I know that I could use ipalias to get it on this
network as well, but of various reasons I don't want
to.

Lets say:
Physical network: 192.168.20.0/24
Default gw: 192.168.20.10
Address of RH 5.2 computer: 10.0.0.2

To rech the default gw I first have to add a route
to 192.168.20.0/24 on eth0.

Then I can set the default route to 192.168.20.10.
No problem.

The problem is that /etc/sysconfig/network-scripts/ifup
adds the default route before it adds other static
routes (calling ifup-post at the very end of the script).

Therefore, the default route cannot be added as it
don't know here the 192.168.20.0 network is.

The only reason for adding default route before other
static routes that I may think of is to be able to
reach a name server that is used to resolve gateway
addresses.

I would say that doing that is a bad habit and that
it is a bug to add the default route before local
static routes are added.

Terje Marthinussen
tm@blom.co.id
Comment 1 Bill Nottingham 1999-09-20 16:33:59 EDT
Fixing this would break static routes on the other side
of the gateway, though. We probably won't fix this.

Note You need to log in before you can comment on or make changes to this bug.