Bug 233507 - two ifcfg-eth's created for one NIC.
two ifcfg-eth's created for one NIC.
Status: CLOSED DUPLICATE of bug 234764
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-22 15:56 EDT by Dave Jones
Modified: 2015-01-04 17:29 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-12 14:54:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Jones 2007-03-22 15:56:38 EDT
From todays rawhide install on an X60.

[davej@cheezit ~]$ cat /etc/sysconfig/network-scripts/ifcfg-eth0 
# Intel Corporation 82573L Gigabit Ethernet Controller
DEVICE=eth0
BOOTPROTO=dhcp
ONBOOT=yes
[davej@cheezit ~]$ cat /etc/sysconfig/network-scripts/ifcfg-eth1
# Intel Corporation 82573L Gigabit Ethernet Controller
DEVICE=eth1
ONBOOT=yes
BOOTPROTO=dhcp
HWADDR=00:16:d3:3a:62:d3
Comment 1 David Cantrell 2007-03-26 14:01:11 EDT
Do you have an iwlwifi adapter in this X60?  I'm seeing this happen on a
laptop-in-a-box system with iwlwifi.  We don't have support for that interface
during installation, but we hit a problem when it comes to gathering interface
descriptions.

We populate the table of interfaces to configure based on what interfaces are
currently available.  Then we gather descriptions for those interfaces using
kudzu.  Kudzu can see the iwlwifi driver and then screws up the descriptions
because kudzu's list of interfaces does not match the list of currently
available interfaces.

Working on it.
Comment 2 David Cantrell 2007-03-26 14:16:43 EDT
Ahh, I see what's happening.  I need the kudzu.PROBE_LOADED flag for
kudzu.probe() in network.py.  Unfortunately, PROBE_LOADED isn't defined in the
Python kudzu module, so here's a patch:

Index: kudzumodule.c
===================================================================
RCS file: /usr/local/CVS/kudzu/kudzumodule.c,v
retrieving revision 1.53
diff -u -p -r1.53 kudzumodule.c
--- kudzumodule.c       9 Aug 2006 17:47:46 -0000       1.53
+++ kudzumodule.c       26 Mar 2007 18:11:43 -0000
@@ -97,6 +97,7 @@ static TableEntry modeTable[] = {
     { "PROBE_ALL",     PROBE_ALL },
     { "PROBE_SAFE",    PROBE_SAFE },
     { "PROBE_ONE",     PROBE_ONE },
+    { "PROBE_LOADED",  PROBE_LOADED },
     { NULL },
 } ;
 static int numModeEntries = sizeof (modeTable) / sizeof (TableEntry);


Bill, can you get a new kudzu built with this enabled?  I need it to fix the
problem in anaconda.
Comment 3 Jeremy Katz 2007-03-26 14:26:53 EDT
kudzu building; will be 1.2.66-1
Comment 4 David Cantrell 2007-03-26 17:37:27 EDT
Fixed in rawhide.
Comment 5 Dave Jones 2007-04-09 17:00:09 EDT
I just did a reinstall with the 20070409 tree, and this still occurs.
Comment 6 David Cantrell 2007-04-09 17:14:58 EDT
Yeah, many other people are reporting it, but it's not anaconda.  It's either
initscripts or something like udev or hal.  Before you click Reboot at the end
of an install, switch over to tty2 and look in
/mnt/sysimage/etc/sysconfig/network-scripts and notice the ifcfg-* scripts are
correct based on the settings you gave during installation.

On reboot, the /etc/init.d/network script is crapping all over these and writing
new files.  I have no idea why.  It might not be initscripts, but something that
initscripts runs.

Reassigning to initscripts.
Comment 7 Bill Nottingham 2007-04-12 14:54:00 EDT

*** This bug has been marked as a duplicate of 234764 ***

Note You need to log in before you can comment on or make changes to this bug.