Bug 233603 - Review Request: guidance - System administration tools
Review Request: guidance - System administration tools
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nigel Jones
Fedora Package Reviews List
:
Depends On: 233602
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-23 08:58 EDT by Rex Dieter
Modified: 2008-08-14 09:45 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-17 10:52:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2007-03-23 08:58:29 EDT
Spec URL: http://apt.kde-redhat.org/apt/kde-redhat/SPECS/guidance.spec
SRPM URL: http://apt.kde-redhat.org/apt/kde-redhat/all/SRPMS.testing/guidance-0.7.1-1.src.rpm

Description:
Guidance is a collection of system administration tools for Linux/KDE systems.
Comment 1 Rex Dieter 2007-03-23 09:10:08 EDT
Depends on pykdeextentions (see bug #233602),

Not very polished packaging-wise yet,
But wanted to get this out there for feedback.


FIXME/TODO items: 

1. guidance-power-manager wants a 'notify' pkg that I haven't found yet (for
fedora):

$/usr/share/apps/guidance/guidance-power-manager.py
Traceback (most recent call last):
  File "/usr/share/apps/guidance/guidance-power-manager.py", line 47, in ?
    from notify import *
ImportError: No module named notify

2. included rpath patch doesn't work as-is, not sure if it's worth bothering
with to fix.
Comment 2 Rex Dieter 2007-05-01 11:52:37 EDT
maybe notify -> pynotify

looks like we have another missing python module:
ImportError: No module named tooltip
Comment 3 Nigel Jones 2007-06-11 07:34:20 EDT
(In reply to comment #2)
> maybe notify -> pynotify
> looks like we have another missing python module:
> ImportError: No module named tooltip
That sounds like it should be in the base python package,

Anyway, per IRC discussion, assigning to self, and will start the review as 
soon as the updates happen.
Comment 4 Vince Schiavoni 2007-06-24 00:55:28 EDT
Reference:
https://sourceforge.net/tracker/?func=detail&atid=512929&aid=1737344&group_id=65974

"guidance" package broken

The guidance software package for FC6
(http://apt.kde-redhat.org/apt/kde-redhat/fedora/6/i386/stable/RPMS/guidanc
e-0.7.1-1.fc6.i386.rpm) is seriously broken.
For various reasons, I wanted to use the KDE desktop and kdm exclusively,
and in order to fully integrate KDE/kdm, it was necessary to remove the
several standard system-config-* software packages so that KDE could "take
over." I had hoped that "guidance" would provide some of the functionality
lost by removing these packages. Several problems immediately surfaced:
1) ~/.xsession-errors: the first line is always: "warning:
/etc/X11/xinit/xinitrc.d/40guidance-displayconfig_restore does not end in
.sh extension, ignoring"; if this is deliberate, I apologize, but nowhere
in the documentation did I find anything telling me to change/fix/configure
this item; if this script is meant to be run at start-up, then it's not
happening; if it's a "fall-back" or "back-up" feature, then I'm confused; I
am not sure whether or not to change this item so that it runs; my display
and desktop are functioning just fine, so I have left it alone;
2) Missing dependencies: PyKDE is required for runtime; the apps included
in guidance did not start until I installed PyKDE - the CLI errors pointed
me towards this; there may be other missing dependencies (PyQt, sip,
pykdeextensions, hsqldb), but these packages were already installed on my box
anyhow;
3) environment variables: after installing PyKDE, CLI errors told me that
some java-type file couldn't be found; I traced this to
/etc/sysconfig/hsqldb, which was looking for a file in the path
"JAVA_HOME", but on my box it's "J2RE_HOME"; I fixed the entry in
/etc/sysconfig/hsqldb, and I realize that this may be a problem with the
latest java and/or hsqldb packages, but without any warning, other users of
guidance will run into the same problems; perhaps guidance could be somehow
told to look-for/pass-on both paths to hsqldb and the other apps it uses at
runtime;
4) Permissions: the apps included in guidance will start for any user,
however, they will not run correctly and/or will yield spurious output
unless run by root; I believe that these apps were meant to be run by root
primarily;
5) Menu entries: the *.desktop items supplied with the package do not
integrate into the KDE menu; I had to manually add them;
6) KDE Kontrol Center: even after all of the above tweaking, guidance apps
will not start inside the KDE Kontrol Center as they are supposed to; I
haven't figured out this problem yet; the typical CLI error is: "Traceback
(most recent call last):
File "/usr/share/apps/guidance/wineconfig.py", line 19, in ?
from qt import *
ImportError: /usr/lib/python2.4/site-packages/qt.so: undefined symbol:
PyUnicode_Type
error: ***failed to import module"; same error for each module
(displayconfig.py, serviceconfig.py, etc.);
7) Other errors: when run as root (or even as a normal user) as stand-alone
apps (outside of Kontrol Center), displayconfig and mountconfig appear to
run and work as intended;
serviceconfig CLI error: "rndc: connect failed: 127.0.0.1#953: connection
refused";
userconfig errors: "Didn't read default DIR_MODE
Didn't read default DIR_MODE
no user removed
no user removed
no user removed";
wineconfig errors: "regedit: Can't export. Registry key
'HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\ThemeManager'
does not exist!
Success
regedit: Can't export. Registry key
'HKEY_CURRENT_USER\Software\Wine\AppDefaults' does not exist!
Success
regedit: Can't export. Registry key
'HKEY_CURRENT_USER\Software\Wine\DllOverrides' does not exist!
Success"

I realize that this is a rather long list, and I apologize in advance if
any of these errors are caused by my own oversights; if any of these items
should be directed to the developer(s) of guidance itself, please let me
know and I will do so. If any additional info is needed, or if I can help
in any other way, please do not hesitate to contact me.

Regards,
Vince
Linux 2.6.20-1.2952.fc6 #1 SMP Wed May 16 18:59:18 EDT 2007 i686 athlon
i386 GNU/Linux
kde-3.4.1-1.0 from KDE-RedHat
guidance-0.7.1-1.fc6 from KDE-RedHat
Comment 5 Vince Schiavoni 2007-06-30 10:14:35 EDT
OK, I'm not really very savvy on this stuff, but I decided to take a risk and
play with this package: I went ahead and changed the name of
/etc/X11/xinit/xinitrc.d/40guidance-displayconfig_restore to
/etc/X11/xinit/xinitrc.d/40guidance-displayconfig_restore.sh, and restarted the
box.  This action fixed several problems:
Item #1) The ~/.xsession-errors stopped;
Item #3) Partly my goof-up: guidance refers to /etc/sysconfig/hsqldb, where the
line: ". /etc/java/java.conf" loads the entry "JAVA_HOME=$JVM_ROOT/java", which
for some reason was commented out by default (!!??); un-commenting this line and
restoring the original /etc/sysconfig/hsqldb (apparently) fixes this item,
however, it begs the questions: a) is hsqldb even required, and must hsqldb be
running for guidance to work correctly, as there are still the other errors? and
b) if /etc/java/java.conf is not correctly configured (and it apparently is not
by default), guidance will still fail completely, as noted previously;
Item #4) Non-privileged use appears to yield the same results, which now appear
in ~/.xsession-errors if guidance is invoked within Kcontrol center; I haven't
had time yet to verify if they are all the same errors as before;
Item #6) The modules now open and function within Kcontrol center as intended;
strangely, there are two identical copies of each, both of which work
identically, but this duplication may be the result of my many tweaks;
Item #7) When run inside Kcontrol, most or maybe all of the runtime errors still
show up (now in ~/.xsession-errors), but I haven't had time yet to verify all of
them.

Hope this info helps. Will forward more info later.

Regards,
Vince
Comment 6 Rex Dieter 2007-07-13 10:48:36 EDT
http://kdeforge.unl.edu/apt/kde-redhat/SOURCES/guidance/guidance.spec
http://kdeforge.unl.edu/apt/kde-redhat/SOURCES/guidance/guidance-0.8.1-1.src.rpm

* Fri Jul 13 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 0.8.0-1
- guidance-0.8.0
- FIXME/TODO: include "^install*" hacks from
http://svn.debian.org/wsvn/pkg-kde/kde-extras/guidance/trunk/debian/rules?op=file
(arg, these install hacks/fixes *really* should be upstreamed, and not required
in packaging).
Comment 7 Rex Dieter 2007-07-13 10:56:28 EDT
fyi, this is a great package, but I have (too) many packages to maintain 
already, so I would very much prefer if someone else would either take over 
maintainership or help comaintain this.  (same goes for pykdeextensions)
Comment 8 Rex Dieter 2007-07-15 22:23:58 EDT
http://kdeforge.unl.edu/apt/kde-redhat/SOURCES/guidance/guidance.spec
http://kdeforge.unl.edu/apt/kde-redhat/SOURCES/guidance/guidance-0.8.1-2.src.rpm

%changelog
* Sun Jul 15 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 0.8.0-2
- BR: libXScrnSaver-devel
Comment 9 Vince Schiavoni 2007-07-22 14:22:38 EDT
Add Item #8) serviceconfig: on serviceconfig start, when reading (is "parsing"
the correct term?) the contents of /etc/rc.d/init.d, serviceconfig displays the
files /etc/rc.d/init.d/.directory (placed there by konqueror) and
/etc/rc.d/init.d/clamav~ (a back-up that I placed there after fixing errors in
atrpms' file); if placing/leaving these files in /etc/rc.d/init.d is "taboo",
then I am in error, but I do not recall seeing any warning anywhere telling me
not to do so; if not, shouldn't serviceconfig be told to ignore hidden and
back-up files?  Also, serviceconfig fails to read the status of many services,
showing a ? instead.  I don't recall the standard Fedora system-config-services
application having any such problems reading the statuses or trying to read
hidden/back-up files, but I can't double-check because I removed it.

In response to Comment #7 by R. Dieter: as much as I would like to help, I lack
the knowledge/skills to do so - "I would if I could but I can't so I won't."

Thank You and Regards,
Vince Schiavoni
Comment 10 Rex Dieter 2008-04-17 10:52:34 EDT
Good news and bad news.

Bad news first: I'm going to withdraw this review request.  My apologies for 
the time and effort spent on this so far.

Good news: looks like much of what was former known as guidance, is getting 
some upstream love, and will likely be making an appearance on some shape or 
form in a future released of kde 4.x (4.1 or 4.2).

Note You need to log in before you can comment on or make changes to this bug.