Bug 233613 - Evolution crashes when accessing Sent folder
Evolution crashes when accessing Sent folder
Status: CLOSED DUPLICATE of bug 238497
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-23 09:35 EDT by Josh Boyer
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-01 12:08:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Josh Boyer 2007-03-23 09:35:59 EDT
Description of problem:

Evolution crashes whenever accessing Sent folder.

Version-Release number of selected component (if applicable):

evolution-2.10.0-2.fc7

How reproducible:

Always

Steps to Reproduce:
1.  Start evo
2.  Click on Sent folder
3.  Marvel at the spectacular way evo crashes
4   Try and restart and it's crashes immediately.  Likely because it's still on
the Sent folder
  
Actual results:

Crash with SIGSEGV

Expected results:

Well... I don't really _expect_ evo to not crash.  But it would be nice :)

Additional info:

GDB backtrace:

(gdb) run
Starting program: /usr/bin/evolution 
[Thread debugging using libthread_db enabled]
[New Thread -1208698640 (LWP 4386)]
CalDAV Eplugin starting up ...
** (evolution:4386): DEBUG: mailto URL command: evolution --component=mail %s
** (evolution:4386): DEBUG: mailto URL program: evolution
[New Thread -1264002160 (LWP 4412)]
[Thread -1264002160 (LWP 4412) exited]
[New Thread -1264002160 (LWP 4413)]
[New Thread -1274885232 (LWP 4414)]
[New Thread -1285375088 (LWP 4415)]
[New Thread -1295864944 (LWP 4416)]
[New Thread -1307575408 (LWP 4417)]
[New Thread -1318065264 (LWP 4418)]
[Thread -1318065264 (LWP 4418) exited]
[New Thread -1318065264 (LWP 4419)]
(evolution:4386): e-data-server-ui-DEBUG: ep_msg_send: in main thread? 0

(evolution:4386): e-data-server-ui-WARNING **: Key file does not have group
'Passwords-Mail'
[New Thread -1382773872 (LWP 4420)]
(evolution:4386): e-data-server-ui-DEBUG: ep_msg_send: in main thread? 0
[New Thread -1383040112 (LWP 4421)]
[New Thread -1393529968 (LWP 4422)]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1208698640 (LWP 4386)]
0x05a221db in camel_message_info_ptr ()
   from /usr/lib/libcamel-provider-1.2.so.10
(gdb) bt
#0  0x05a221db in camel_message_info_ptr ()
   from /usr/lib/libcamel-provider-1.2.so.10
#1  0x039e4599 in ml_tree_value_at (etm=0x80d4b20, path=0x8580a40, col=20, 
    model_data=0xb2109848) at message-list.c:1286
#2  0x04a06ea6 in etmc_value_at (etm=0x80d4b20, node=0x8580a40, col=20)
    at e-tree-memory-callbacks.c:104
#3  0x04a085b1 in e_tree_model_value_at (etree=0x80d4b20, node=0x8580a40, 
    col=20) at e-tree-model.c:783
#4  0x049fa9e9 in e_table_sorting_utils_tree_sort (source=0x80d4b20, 
    sort_info=0x8571b80, full_header=0x824d048, map_table=0x860ec90, count=780)
    at e-table-sorting-utils.c:287
#5  0x04a0f01a in resort_node (etta=0x825d450, gnode=0x85e7b90, recurse=1)
    at e-tree-table-adapter.c:183
#6  0x04a1041f in generate_tree (etta=0x825d450, path=<value optimized out>)
    at e-tree-table-adapter.c:374
#7  0x04a10c1c in etta_proxy_node_changed (etm=0x80d4b20, path=0x8585a20, 
    etta=0x825d450) at e-tree-table-adapter.c:483
#8  0x00ce76b9 in g_cclosure_marshal_VOID__POINTER ()
   from /lib/libgobject-2.0.so.0
#9  0x00cdad9b in g_closure_invoke () from /lib/libgobject-2.0.so.0
#10 0x00ceb433 in ?? () from /lib/libgobject-2.0.so.0
#11 0x00cec957 in g_signal_emit_valist () from /lib/libgobject-2.0.so.0
#12 0x00cecb19 in g_signal_emit () from /lib/libgobject-2.0.so.0
---Type <return> to continue, or q <return> to quit---
#13 0x04a09847 in e_tree_model_node_changed (tree_model=0x80d4b20, 
    node=0x8585a20) at e-tree-model.c:259
#14 0x04a07453 in e_tree_memory_thaw (etmm=0x80d4b20) at e-tree-memory.c:203
#15 0x039e5628 in regen_list_regened (mm=0x8203a00) at message-list.c:2421
#16 0x039d4962 in periodic_processing () at mail-mt.c:465
#17 0x0084dbf6 in ?? () from /lib/libglib-2.0.so.0
#18 0x0084d622 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#19 0x008505ff in ?? () from /lib/libglib-2.0.so.0
#20 0x008509a9 in g_main_loop_run () from /lib/libglib-2.0.so.0
#21 0x052b07e3 in bonobo_main () from /usr/lib/libbonobo-2.so.0
#22 0x0805ebc6 in main (argc=1, argv=0xbff5af14) at main.c:610
(gdb)
Comment 1 Josh Boyer 2007-03-23 10:15:46 EDT
Seems removing .evolution/mail/config/* has fixed the instant crash on restart
problem, likely only because it moved the current view off my Sent folder.

I should point out that the Sent folder is on an IMAP server, not the local one.
Comment 2 Matthew Barnes 2007-03-23 17:26:22 EDT
Now that you've removed .evolution/mail/config/*, does clicking on your IMAP
Sent folder still crash the program?
Comment 3 Josh Boyer 2007-03-26 10:05:32 EDT
(In reply to comment #2)
> Now that you've removed .evolution/mail/config/*, does clicking on your IMAP
> Sent folder still crash the program?

Yes.
Comment 4 Josh Boyer 2007-04-04 16:19:57 EDT
I removed .evolution/mail/views/current_view-imap:<stuff here>_Sent.xml and
.evolution/mail/views/custom_view-imap:<stuff here>_Sent.xml and can now access
the Sent folder with it crashing.  Must have been something it didn't like about
whatever email it was stuck on before?
Comment 5 Matthew Barnes 2007-04-04 17:12:22 EDT
If you can find a way to post the offending email (or send it to me privately)
that would be very useful to help track down the source of the crash.
Comment 6 Josh Boyer 2007-04-04 17:53:19 EDT
(In reply to comment #5)
> If you can find a way to post the offending email (or send it to me privately)
> that would be very useful to help track down the source of the crash.

I've started going through each email individually.  There are 981 of them, so
bear with me.  So far, no crash.  If I recreate it, I'll send it your way.

I have a feeling the problem will have magically vanished.
Comment 7 Josh Boyer 2007-04-05 11:10:05 EDT
Went through them all with no crash.  I'll stick this bug in NEEDINFO for a
while to see if a recreate does eventually happen.  If not, it can likely be
closed as WORKSFORME or something.
Comment 8 Josh Boyer 2007-04-13 09:39:12 EDT
Ok, did some more digging and got a recreate.  It seems that sorting by the "To"
field (i.e. by clicking the "To" label) in my Sent folder will immediately crash
Evo and the problem persists until I remove the 
.evolution/mail/views/{current,custom}_view... files.
Comment 9 Matthew Barnes 2007-05-01 12:08:39 EDT

*** This bug has been marked as a duplicate of 238497 ***

Note You need to log in before you can comment on or make changes to this bug.