Bug 233637 - links for packages with special characters in their name broken in webui
links for packages with special characters in their name broken in webui
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site (Show other bugs)
rhn500
All Linux
medium Severity medium
: ---
: ---
Assigned To: Justin Sherrill
wes hayutin
: Reopened
Depends On:
Blocks: 248643 317791
  Show dependency treegraph
 
Reported: 2007-03-23 11:20 EDT by Máirín Duffy
Modified: 2008-04-02 17:08 EDT (History)
1 user (show)

See Also:
Fixed In Version: sat510
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-02 17:08:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
note how gcc-c++-ssa is in the list (104.05 KB, image/png)
2007-03-23 11:20 EDT, Máirín Duffy
no flags Details
see how gcc-c++-ssa is not found. it has also been renamed to 'gcc-c -saa' on the page (68.92 KB, image/png)
2007-03-23 11:22 EDT, Máirín Duffy
no flags Details

  None (edit)
Description Máirín Duffy 2007-03-23 11:20:29 EDT
NOTE: I am opening this bug as public so customers can follow along.

Description of problem:

Basically, links for packages that have special characters in their name are
broken in the webui. When you click on them, you receive a "no package" message.
The links are from a package search results page; not sure if there are other
links to these packages (in say channel details > packages tab) that are
similarly broken. Here are some example packages that have broken links:

compat-gcc-c++
gcc-c++
gcc-c++-ssa

Sam Sharpe on nahant-list came up with a workaround:

"You need to manually replace the + in the destination URL with %2B, like
so:

https://rhn.redhat.com/network/software/packages/name_overview.pxt?package_name=gcc-c%2b%2b-ssa&channel_arch_ia32=channel-ia32&channel_arch_ia64=channel-ia64&channel_arch_x86_64=&search_subscribed_channels=
"

Please refer to
https://www.redhat.com/archives/nahant-list/2007-March/msg00219.html for the
full customer description of the issue.
Comment 1 Máirín Duffy 2007-03-23 11:20:30 EDT
Created attachment 150766 [details]
note how gcc-c++-ssa is in the list
Comment 2 Máirín Duffy 2007-03-23 11:22:16 EDT
Created attachment 150767 [details]
see how gcc-c++-ssa is not found. it has also been renamed to 'gcc-c -saa' on the page
Comment 3 Brandon Perkins 2007-09-27 18:55:04 EDT
I wan this rechecked.
Comment 4 wes hayutin 2007-09-28 09:13:13 EDT
works fine in 5.1 build 8

package gcc-c++-3.4.6-8.i386.rpm Help Icon

    * Details
    * New Versions
    * Installed Systems
    * Target Systems

    * Overview
    * Dependencies
    * Change Log
    * File List

Comment 6 John Ha 2007-12-03 20:26:14 EST
Here is a release note for this issue as suggested by Mairin:

 A bug was fixed where the Details page for packages whose names contain a
 special character, such as a plus sign (`+`), would display a "no package" error.
Comment 7 Mike McCune 2008-03-17 15:34:33 EDT
release_pending
Comment 8 Brandon Perkins 2008-04-02 17:08:30 EDT
UI Enhancements for 5.1 Sat GA so Closed for Current Release.

Note You need to log in before you can comment on or make changes to this bug.