Bug 233647 - missing casts in kernel header file cause vmware module build to fail
missing casts in kernel header file cause vmware module build to fail
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-23 11:54 EDT by Jonathan Kamens
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-26 01:39:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2007-03-23 11:54:26 EDT
The call to __cpuid in the cpuid_count function in asm-i386/processor.h needs to
cast the four arguments to __cpuid to unsigned int *, to avoid a type warning
when  this header file is used.  This is harmless most of the time, but harmful
when it is used while trying to build vmware modules, since the module build
code treats warnings as errors and hence draws incorrect conclusions about the
availability of various kernel features.
Comment 1 Dave Jones 2007-03-26 01:39:41 EDT
The warnings will be turned off before release.
Building release versions of code with -Werror is a really bad idea anyway.

Note You need to log in before you can comment on or make changes to this bug.