Bug 233726 - alsa-lib-1.0.14-0.1.rc1.fc6 breaks xine/mplayer sound
alsa-lib-1.0.14-0.1.rc1.fc6 breaks xine/mplayer sound
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: system-config-soundcard (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
: Regression, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-23 23:10 EDT by Bradley
Modified: 2007-11-30 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-17 05:17:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
system-config-soundcard log with 1.0.13 (60.21 KB, text/plain)
2007-03-23 23:10 EDT, Bradley
no flags Details
system-config-soundcard output with 1.0.14 (54.38 KB, text/plain)
2007-03-23 23:12 EDT, Bradley
no flags Details

  None (edit)
Description Bradley 2007-03-23 23:10:28 EDT
Description of problem:

Upgrading alsa to alsa-lib-1.0.14-0.1.rc1.fc6 breaks xine/mplayer sound.

system-config-soundcard's tests works fine, but mplayer/xine are silent.

I tried both the new kernel is today's updates (kernel-2.6.20-1.2933.fc6, vs the
previous kernel-2.6.20-1.2925.fc6) and the kernel makes no difference

Version-Release number of selected component (if applicable):

alsa-lib-1.0.14-0.1.rc1.fc6 fails
alsa-lib-1.0.13-1.fc6 is fine

FWIW:

xine-0.99.4-10.lvn6
mplayer-1.0-0.71.rc1.lvn6

How reproducible:

xine <some file>

Steps to Reproduce:
1. Upgrade to ltest errata release of alsa-libs
2. use xine or mplayer to play a file - I'm using lca2006 .oggs, but it appears
to be any file
3. Hear no sound
  
Actual results:

No sound

Expected results:

Sound

Additional info:

Downgrading to alsa-libs 1.0.13 fixes this. I'll attach system-config-soundcard
logs for both versions
Comment 1 Bradley 2007-03-23 23:10:29 EDT
Created attachment 150816 [details]
system-config-soundcard log with 1.0.13
Comment 2 Bradley 2007-03-23 23:12:14 EDT
Created attachment 150817 [details]
system-config-soundcard output with 1.0.14
Comment 3 Anthony Messina 2007-03-24 04:05:27 EDT
I can verify that snd-hda-intel no longer works, though it does get loaded. 
Output from aplay -l:

**** List of PLAYBACK Hardware Devices ****
ALSA lib control.c:910:(snd_ctl_open_noupdate) Invalid CTL hw:0
aplay: device_list:213: control open (0): No such file or directory

system-config-soundcard does create the required /etc/asound.conf file, to no avail.

It worked perfectly in the previous fc6 rpm.
Comment 4 Martin Stransky 2007-03-26 05:34:37 EDT
Can you please check packages from devel? (alsa-lib-1.0.14rc3 and
alsa-utils-1.0.14rc2)

(http://download.fedora.redhat.com/pub/fedora/linux/core/development/)
Comment 5 Martin Stransky 2007-03-26 05:42:48 EDT
Hm, works fine for me...do you use IEC958?
Comment 6 Bradley 2007-03-26 05:52:48 EDT
I'm not sure what that is ;) but I tried system-config-soundcard with both
settings for the second tab ('default PCM define'), didn't make a difference
that I can see.

The devel alsa stuff didn't help either - the test sound is fine, xine fails.
Comment 7 Martin Stransky 2007-03-26 06:54:03 EDT
defaults.pcm.device must be 0 (the first one, in /etc/asound.conf), 4 is a
digital optical output (IEC958).

Please check packages from devel.
Comment 8 Bradley 2007-03-26 07:23:00 EDT
The following /etc/asound.conf works with 1.0.13:

#Generated by system-config-soundcard, do not edit by hand
#SWCONF
#DEV 4
defaults.pcm.card 0 
defaults.pcm.device 4 
defaults.ctl.card 0 

It doesn't work with devel (1.0.14-0.3.rc3; .rc2 for alsa-utils). It does work
if I ignore the command and manually change defaults.pcm.device to 0. After that
change it also works with alsa* from fc6-updates.
Comment 9 Aaron Gaudio 2007-04-02 13:25:51 EDT
Indeed, I get the same problem. I've got an Intel ICH7 sound card. When I
upgrade to the 1.0.14 alsa-lib, sound stops working, not just for xine and
mplayer, but for everything (flash-plugin, sox, aplay, etc.).

I found that the only thing that works in this case, strangely enough, is to use
-ao oss for mplayer. This passes through to the OSS emulation in alsa, and
appears to work. Mplayer with oss was the only thing that could play sound
though (none of the other normal oss apps that use /dev/dsp did).

Downgrading to 1.0.13 restores all my sounds. I don't have my soundcard set to
use IEC958, just "Intel ICH7".
Comment 10 Aaron Gaudio 2007-04-02 13:46:01 EDT
Looks like I spoke too soon. My device actually *was* set to use IEC958 (on the
2nd tab). I changed it to just Intel ICH7, and it didn't work at first (testing
with mplayer). Then I checked the "Disable specific card configuration" and it
worked. When I unchecked it, it still worked. Whaddya know. My /etc/asound.conf
looked like Bradley's before, now it looks like this:

#Generated by system-config-soundcard, do not edit by hand
#SWCONF
#DEV 0
defaults.pcm.card 0 
defaults.pcm.device 0 
defaults.ctl.card 0 
Comment 11 Martin Stransky 2007-04-10 07:48:29 EDT
okay, closing...
Comment 12 Bradley 2007-04-10 09:45:12 EDT
Err, no. It worked, then it stopped, so its a bug.

I shouldn't have to hand edit config files (especially ones that say 'do not
edit by hand') to restore functionality that was broken as part of an fc6 update.
Comment 13 Martin Stransky 2007-05-16 08:28:50 EDT
I can't reproduce it here. So if you want me to fix it, please downgrade to
1.0.13, create a log (root/scsconfig.log) and attach it here. Then try to update
to 1.0.14 and check the log again. The /etc/modprobe.conf should be the same...
Comment 14 Bradley 2007-05-16 10:21:09 EDT
I attached both scsconfig files when the bug was created - see attachment 150816 [details]
(1.0.13) and attachment 150817 [details] (1.0.14)
Comment 15 Martin Stransky 2007-05-16 10:27:32 EDT
Aha. I really don't know why 1.0.13 works with this /etc/modprobe.conf:

------- /etc/asound.conf --------
#Generated by system-config-soundcard, do not edit by hand
#SWCONF
#DEV 4
defaults.pcm.card 0 
defaults.pcm.device 4 
defaults.ctl.card 0 

This configuration isn't correct.

If 1.0.13 works with a broken config, it's a bug in 1.0.13, not in 1.0.14.

Closing as not a bug.
Comment 16 Bradley 2007-05-16 18:46:21 EDT
system-config-soundcard generated that, so then its a bug in that
Comment 17 Martin Stransky 2007-05-17 05:17:38 EDT
system-config-soundcard generates what the user tells it. I've checked it and
works fine. There was a problem with savig the current configuration in
system-config-soundcard, but it's fixed in FC7 now. Closing again. If you think
there's a bug, please write steps how to reproduce it and/or attach a patch for it.

Note You need to log in before you can comment on or make changes to this bug.