Bug 233735 - Xinerama: XineramaQueryScreens() returns only the first screen
Summary: Xinerama: XineramaQueryScreens() returns only the first screen
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-24 10:36 UTC by Jan Andres
Modified: 2018-04-11 16:19 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-26 16:07:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The test program mentioned in the report (910 bytes, text/plain)
2007-03-24 10:37 UTC, Jan Andres
no flags Details
My xorg.conf (2.66 KB, text/plain)
2007-03-24 10:38 UTC, Jan Andres
no flags Details

Description Jan Andres 2007-03-24 10:36:54 UTC
Since I upgraded to xorg-x11-server-Xorg-1.2.99.902-1.fc7,
XineramaQueryScreens() only returns information about the first screen, although
a second one exists. This breaks Xinerama-aware applications, including
metacity, because they are unable to determine the size of the second screen.

Please see attached small C program that I wrote as a debugging aid; this is its
output on my system:

screen count: 2; default screen: 0
[screen 0] width=1920 height=1200
[screen 1] width=1024 height=768
Xinerama is active.
Xinerama: found 1 screens
[screen 0] x_org=0 y_org=0 width=1920 height=1200

Also attached is my xorg.conf. I'm running Nvidia binary driver version 9746;
note that Xinerama has worked with this driver version with the
xorg-x11-server-Xorg I was running earlier. Sorry, I don't have its version
number any more.

Regards,
Jan

Comment 1 Jan Andres 2007-03-24 10:37:55 UTC
Created attachment 150822 [details]
The test program mentioned in the report

Comment 2 Jan Andres 2007-03-24 10:38:30 UTC
Created attachment 150823 [details]
My xorg.conf

Comment 3 Jan Andres 2007-03-24 11:51:41 UTC
Update: not fixed by upgrading to Nvidia version 9755.

The problem is that screenInfo.numScreens within the X server is 0. Trying to
figure out why...

Comment 4 Jan Andres 2007-03-24 13:55:07 UTC
Okay, got the last one wrong. screenInfo.numScreens was in fact correctly
initialized. The problem was that PanoramiXNumScreens wasn't, because
PanoramiXExtensionInit() was never called. And it's correct that it wasn't, as
Xinerama isn't enabled in xorg.conf.

So, the actual source of the problem is that the server reports Xinerama to be
enabled although it actually isn't, and the Xinerama extension then of course
isn't working properly.

Comment 5 Matěj Cepl 2007-03-26 16:07:28 UTC
Hi, Jan,

we really cannot support 3rd party proprietary "nvidia" video driver, and there
is no way how to persuad us that the bug is in our Xserver and not in their
drivers. So, I am closing this for now as CANTFIX (because we really cannot fix
it), and when you will be able to reproduce the bug with nv (or vesa) drivers,
feel free to reopen this bug (while attaching to this bug uncompressed separate
attachments of /etc/X11/xorg.conf and /var/log/Xorg.0.log demonstrating the
problem).

Thanks a lot, and sorry that I cannot help you immediately.


Note You need to log in before you can comment on or make changes to this bug.