Bug 233747 - starting hp-toolbox gives a traceback
starting hp-toolbox gives a traceback
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-24 12:24 EDT by Bernard Johnson
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-29 14:52:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bernard Johnson 2007-03-24 12:24:05 EDT
Description of problem:
starting hp-toolbox gives a traceback

Version-Release number of selected component (if applicable):
hplip-1.6.12-1.fc6

How reproducible:
Always (but suspect it's related to my low toner condition)

Steps to Reproduce:
1. run hp-toolbox from shell
2.
3.
  
Actual results:
$ hp-toolbox

HP Linux Imaging and Printing System (ver. 1.6.12)
HP Device Manager ver. 6.3

Copyright (c) 2003-6 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Traceback (most recent call last):
  File "/usr/share/hplip/ui/devmgr4.py", line 700, in InitialUpdate
    self.RescanDevices()
  File "/usr/share/hplip/ui/devmgr4.py", line 732, in RescanDevices
    self.DeviceListRefresh()
  File "/usr/share/hplip/ui/devmgr4.py", line 1066, in DeviceListRefresh
    self.UpdateDevice()
  File "/usr/share/hplip/ui/devmgr4.py", line 827, in UpdateDevice
    self.UpdateHistory()
  File "/usr/share/hplip/ui/devmgr4.py", line 1207, in UpdateHistory
    self.cur_device.hist = self.cur_device.queryHistory()
  File "/usr/share/hplip/base/device.py", line 1962, in queryHistory
    yr, mt, dy, hr, mi, sec, wd, yd, dst, job, user, ec = x.strip().split(',', 14)
ValueError: too many values to unpack


printing x before the traceback gives:
"2007,3,24,9,57,49,5,83,1,0,bjohnson,1804,Low toner.,"

I'll post this to the hplip-devel mailing list since it appears to be an
upstream issue.
Comment 1 Bernard Johnson 2007-03-29 14:52:15 EDT
HPLIP developers described this as a "possible file conflict" and suggested that
I uninstall and reinstall the hplip rpms.

That worked, and the error no longer happens.

How can that happen with a RPM?  I dunno.  Unfortunately, I can't debug it
further, so I'm going to close it as NOTABUG unless I see it again.
Comment 2 Bernard Johnson 2007-04-17 00:02:25 EDT
Thinking back on this, I'm pretty sure it was caused by bug #236445.

Note You need to log in before you can comment on or make changes to this bug.