Bug 233748 - FC7T2 hard lock with r8169 module
Summary: FC7T2 hard lock with r8169 module
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: rawhide
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
Assignee: John W. Linville
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-24 16:34 UTC by Bernd Bartmann
Modified: 2007-11-30 22:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-20 19:42:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of dmesg (39.10 KB, text/plain)
2007-03-24 16:35 UTC, Bernd Bartmann
no flags Details
output of lspci -v (8.39 KB, text/plain)
2007-03-24 16:36 UTC, Bernd Bartmann
no flags Details

Description Bernd Bartmann 2007-03-24 16:34:25 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

Description of problem:
I've installed FC7T2 + latest rawhide kernel 2.6.20-1.3017.fc7 for x86_64. My system has an Intel Pro1000/MT PCI network card (e1000 module) as eth0 and a Realtek RTL8168b/8111b PCI-E network card (r8169 module) as eth1.

When both cards have a network link they get their IP addresses via DHCP and everything is fine.

When the e1000 card is not connected to the network DHCP fails of course for this card. Afterwards it tries DHCP on the r8169 card and then the system locks hard. I can see a call trace with several lines for the r8169 module on the console but nothing is logged to /var/log/messages.


Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1. have a Intel Pro1000/MT PCI card as eth0 (e1000 module) and a Realtek RTL8168b/8111b PCI-E card (r8169 module) as eth1
2. boot the system with eth0 disconnected from the lan and eth1 connected to the lan
3. both eth0 and eth1 should be set to use DHCP

Actual Results:


Expected Results:


Additional info:

Comment 1 Bernd Bartmann 2007-03-24 16:35:20 UTC
Created attachment 150831 [details]
output of dmesg

Comment 2 Bernd Bartmann 2007-03-24 16:36:10 UTC
Created attachment 150832 [details]
output of lspci -v

Comment 3 Bernd Bartmann 2007-03-31 15:32:57 UTC
Now I'm on FC7T3 with todays rawhide kernel and it's gotten even worse. Even if
both network card have a link to the lan the system sometimes locks up hard
while trying to get the DHCP infos for the Realtek card.

Comment 4 william.hoffmann 2007-04-11 18:32:11 UTC
Same problem on 2.6.20-1.3056.fc7 ( i686 ) but with only one onboard network card :

01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI
Express Gigabit Ethernet controller (rev 01)
        Subsystem: ASRock Incorporation Unknown device 8168
        Flags: bus master, fast devsel, latency 0, IRQ 17
        I/O ports at e800 [size=256]
        Memory at febff000 (64-bit, non-prefetchable) [size=4K]
        Expansion ROM at febc0000 [disabled] [size=128K]
        Capabilities: [40] Power Management version 2
        Capabilities: [48] Vital Product Data
        Capabilities: [50] Message Signalled Interrupts: Mask- 64bit+ Queue=0/1
Enable-
        Capabilities: [60] Express Endpoint IRQ 0
        Capabilities: [84] Vendor Specific Information


Found in /var/log/messages => kernel: NETDEV WATCHDOG: eth0: transmit timed out


Comment 5 John W. Linville 2007-04-19 21:46:31 UTC
Bernd, please try the latest rawhide kernel available.  It has a fix for 
lockups with r8168 devices.  Does it work better for you?

William, I think you probably have a different issue.  Could you open a new 
bug with the details of the issue you are seeing?  Thanks!

Comment 6 Bernd Bartmann 2007-04-20 18:27:32 UTC
John, I'm now on kernel-2.6.20-1.3094.fc7.x86_64 and I can't reproduce the
problem anymore. I rebooted the system several times with the e1000 card
connected and unconnected and got no lock-up so far. Good job.

BTW: Will this fix be in the kernel of FC7T4?


Comment 7 John W. Linville 2007-04-20 19:42:59 UTC
I don't think that is frozen yet, so I assume so.

Thanks for the feedback!

Comment 8 william.hoffmann 2007-04-21 19:02:16 UTC
(In reply to comment #5)
> Bernd, please try the latest rawhide kernel available.  It has a fix for 
> lockups with r8168 devices.  Does it work better for you?
> 
> William, I think you probably have a different issue.  Could you open a new 
> bug with the details of the issue you are seeing?  Thanks!
Yes it wasn't exactly the same issue ... but the card works perfectly know with 
2.6.20-1.3094.fc7.
Thanks

Comment 9 Bernd Bartmann 2007-04-21 19:05:30 UTC
BTW: What can we do to get this driver into RHES5 ASAP?

Comment 10 John W. Linville 2007-04-26 20:49:42 UTC
Bernd, please feel free to open a bug against RHEL5.

Comment 11 Bernd Bartmann 2007-04-27 19:41:37 UTC
I've opened an RFE-bug against RHES5: 238187


Note You need to log in before you can comment on or make changes to this bug.