Bug 233749 - kernel-xen sporadically reboots
kernel-xen sporadically reboots
Status: CLOSED DUPLICATE of bug 233937
Product: Fedora
Classification: Fedora
Component: kernel-xen (Show other bugs)
All Linux
medium Severity high
: ---
: ---
Assigned To: Xen Maintainance List
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2007-03-24 12:57 EDT by Bernard Johnson
Modified: 2007-11-30 17:12 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-04-04 09:47:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Bernard Johnson 2007-03-24 12:57:04 EDT
Description of problem:
kernel-xen will sporadically reboot after a few minutes of use.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. login in (gui - gdm)
2. run a few things, usually less than 2 minutes
3. watch reboot
Additional info:
There is nothing in the log files that indicate a failure.  This did not happen
with kernel-xen-2.6.19-1.2911.6.5.fc6.  The non-xen kernel appears to be
completely stable, so far.
Comment 1 Claus Reheis 2007-03-24 19:07:49 EDT
Same here!

Smolt Profile of my machine:
Comment 2 Jan ONDREJ 2007-03-28 02:44:14 EDT
Exactyly same problem with all of my three machines (notebook and 2 virtual
servers). Each machine hangs in different times (from 15 mins. to 3 days), but
all of them hangs finally.

Another problem is, that some applications hangs before (for example apcsmart
daemon from nut package hangs after some minutes (1-2?).
Comment 3 Scott Sanders 2007-04-02 09:15:43 EDT
Same here. Tested on a Dell 2850 and an HP Proliant DL380. I believe this is due
to memory corruption caused by the Xen patches. According to Xen developers I
have spoken to, the 2.6.20 kernel is not fully supported by Xen yet and likely
should not be included in the yum repositories. To rapidly duplicate the
problem, install iozone and let it run for a few minutes (seconds). The machine
will hang and then reboot. Building the Xen kernel from mercurial sources works
terrific on an identical fc6 installation, leading me to blieve the problem is
in the 2.6.20 kernel-xen package.
Comment 4 Eduardo Habkost 2007-04-02 09:55:27 EDT
This looks like a duplicate of bug #233937
Comment 5 Eduardo Habkost 2007-04-04 09:47:34 EDT
This has the same symptoms of bug #233937 and are likely to have the same 
cause, so marking as duplicate of it.

If after fixing one problem some people continue getting the problems (that 
will mean they had different causes), we divide the bugs again.

*** This bug has been marked as a duplicate of 233937 ***
Comment 6 Rolf Fokkens 2007-04-04 17:08:54 EDT
Same problem here with kernel-xen-2.6.20-1.2933.fc6, haven't reverted to older
kernels to see if those fix the problem.

Hardware: CPU: AMD Athlon(tm) 64 X2 Dual Core Processor 3600+, 1.5 GB RAM

Note You need to log in before you can comment on or make changes to this bug.