Bug 233814 - Parallels Desktop for Mac Optical Drive not recognized
Parallels Desktop for Mac Optical Drive not recognized
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
http://forums.parallels.com/showthrea...
:
Depends On:
Blocks: 199990
  Show dependency treegraph
 
Reported: 2007-03-25 06:12 EDT by Eric Kerby
Modified: 2008-01-07 21:42 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.6.23?
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-07 21:42:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Kerby 2007-03-25 06:12:55 EDT
Description of problem:
This testing was done on a Mac Pro in a Parallels Desktop (build 3188) for Mac
virtual machine set to OS Type: Linux and OS Version: Fedora Core Linux.  This
install was done as Fedora 7 test 1 upgraded to test 2 since I get a kernel
panic after a fresh install of test 2 (bug id 230696).

When booting the virtual machine from the F7test2 install CD ISO with Parallels
the optical drive does not get recognized properly by kernel versions in Fedora
7.  The anaconda installer begins to start up, but shortly the red on blue
interface asks for your keyboard type and then proceeds to ask for a driver
since it did not detect the optical drive.  None of the drivers in the list
work.  A network install has been the only way for me to install Fedora 7 test
versions.  All kernels in Fedora Core 6, including 2.6.20-1.2933.fc6, have been
able to read the optical drive flawlessly.

When working in a Fedora 7 installation with kernel versions at least later than
2.6.20-1.2949.fc7 (I did not write down earlier versions used in test1), no
optical drive shows up in Nautilus or in the /dev/ directory.  FC6 kernels read
the drive fine and the CD drive shows up in the Computer list as CD-RW/DVD+RW
and shows up on the desktop after logging in.


Version-Release number of selected component (if applicable):
Fedora 7 test 1 and test 2
kernel 2.6.20-1.2949.fc7
kernel 2.6.20-1.3003.fc7
kernel 2.6.20-1.3017.fc7

How reproducible:
With the listed kernel versions, always.

Steps to Reproduce:
1. Create a Linux VM in Parallels Desktop for Mac
2. Install Fedora 7 test 1 or test 2 (if possible)
3. Try to mount a CD or ISO
  
Actual results:
The Parallels optical drive is not detected.

Expected results:
The Parallels optical drive is detected properly and an inserted disc or
virtualized ISO is mounted properly.

Additional info:
The optical drive installed in my Mac Pro as reported by Apple is: SONY DVD RW
DW-D150A. In Ubuntu, if I right click on the drive in the Computer list, click
Properties, and go to the Drive tab, the Model listed is: PRL CD-ROM [1] and
Firmware: FMR10003. I assume PRL there stands for Parallels since they
virtualize most hardware components in that way.

I would blame Parallels for this problem, but I have to claim this is a kernel
bug since earlier kernel versions in FC6 worked flawlessly.  Also note that both
the desktop and alternate versions of the Ubuntu Feisty Beta install CD fail to
boot on this virtual machine due to the optical drive problem.  See:
https://launchpad.net/ubuntu/+source/linux-source-2.6.20/+bug/95830

If there is any more information I could provide that would help fix this issue,
I would be more than glad to help. I obviously have a high interest in seeing
this resolved. I also wonder if other Parallels for Mac users are experiencing this.
Comment 1 Eric Kerby 2007-03-28 19:59:54 EDT
I thought it would be worth mentioning at this time that Phillip Lougher on the
Ubuntu side has been making some progress narrowing down the similar kernel bug
I filed in Ubuntu's Launchpad.  See the bug here: https://launchpad.net/bugs/95830

If a kernel maintainer is able to work on this issue (that is a serious problem
for Parallels Desktop Mac users), I would recommend reading the comments Phillip
has added to my original bug filing.  Basically, he has tracked down the issue
to the ata_piix driver.

Thanks,
Eric
Comment 2 Chris Wicklein 2007-03-29 15:42:12 EDT
An easier way to reproduce the problem is to simply boot from the Fedora 7 test
2 live CD.
Comment 3 Julio Merino 2007-04-09 06:50:05 EDT
I'm now hitting this same problem with Fedora Core 7 test 3 installation DVD.

Here are some more details from a running Fedora Core 6 system in the same
Parallels installation, which works flawlessy:

fedora:~> dmesg | grep -i ide
BIOS-provided physical RAM map:
CPU: After generic identify, caps: 0f80b9b9 00000000 00000000 00000000 00000001
00000000 00000000
Boot video device is 0000:00:02.0
Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
ICH2: IDE controller at PCI slot 0000:00:1f.1
    ide0: BM-DMA at 0x6800-0x6807, BIOS settings: hda:DMA, hdb:DMA
Probing IDE interface ide0...
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
Probing IDE interface ide1...
ide-floppy driver 0.99.newide
Comment 4 Eric Kerby 2007-04-28 15:43:45 EDT
Problem is still present in Fedora 7 Test 4.

Please look into fixing this soon.  On the Ubuntu side, a fix finally just got
committed that should have the virtual optical drive working again when the next
kernel update is released, but they missed the final Feisty deadline.  This
means that all new Ubuntu media and the install ISO will not be functional with
Parallels for the next six months until Gutsy Gibbon is released.

I don't want that to happen to Fedora as well, which is a more supported version
of Linux for use with Parallels.  Please check into the work that was done for
the following Ubuntu bug to help fix this ASAP.  https://launchpad.net/bugs/95830
Comment 5 Eric Kerby 2007-04-28 16:28:53 EDT
I updated Test 4 to kernel version 2.6.21-1.3116, and the optical drive is not
recognized in this newest version either.
Comment 6 Ruben Kerkhof 2007-05-25 13:14:52 EDT
Still present in F-7 RC2. A workaround is to create the virtual machine with OS Type "Solaris" instead of 
Fedora Core Linux.
Comment 7 Eric Kerby 2008-01-07 21:42:58 EST
Not sure when this was fixed, or whether a kernel change or Parallels itself
fixed it, but the optical drive shows up properly now in Fedora 8.

Note You need to log in before you can comment on or make changes to this bug.