Bug 233843 - Kernel Lockup after successful boot.
Kernel Lockup after successful boot.
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
6
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-25 07:36 EDT by Leslie Satenstein
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-01 16:45:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.conf file as requested (570 bytes, text/plain)
2007-03-26 20:24 EDT, Leslie Satenstein
no flags Details
xorg log file (95.33 KB, text/plain)
2007-03-26 20:28 EDT, Leslie Satenstein
no flags Details
xorg (62.40 KB, text/plain)
2007-03-26 20:38 EDT, Leslie Satenstein
no flags Details
FC7 Boot messages (log file) (41.48 KB, text/plain)
2007-05-14 16:32 EDT, Leslie Satenstein
no flags Details
The X windows log file up to the point of the crash. (61.15 KB, text/plain)
2007-05-14 16:34 EDT, Leslie Satenstein
no flags Details

  None (edit)
Description Leslie Satenstein 2007-03-25 07:36:22 EDT
Description of problem:

Kernel 2933 and x windows clash with full system lockup

Version-Release number of selected component (if applicable):

initrd-2.6.20-1.2933.fc6xen.img

How reproducible:

yum install kernel


Steps to Reproduce:
1. Boot system with new kernel
2.
3.
  
Actual results:
System shows the boot process in the same way as the previous kernel boots.
I see line by line following udev

Then when the gnome switch is attempted, only a black screen is present with a
locked keyboard (no lights) or mouse activity possible. 

Expected results:

I expected this to work the same as the previous version. 2798. (system was
rebuilt just to prove point. I spent 12 hours trying to debug this and a
x-windows problem.

Additional info:

This is a x-windows and kernel conflict when the device is a i810 mother board.
I will try again with the default x config setup driver set to vesa. If there is
a change, I will repost.
  

Intel video bios is dated march 2007. Mother board is a intel 945gnt, with the
following:

Video build 1374 PC 14.12 08/28/2006 at 16:30.16
Comment 1 Leslie Satenstein 2007-03-25 08:25:57 EDT
Following further hours of boot / reboots, the problem is the incompatibilty
between my standard intel mother board, (which works for every other fedora
kernel version), the most recent mouse driver for x (2 minute to detect) and
x-windows server.

I have reported this as a x-windows problem, but it may very well be a kernel
problem.

I on my dual core system is here to help.

My system.  Intel d945gnt mother board, processors d930, 1 gig memory, sata boot
drive.

Please attempt to resolve.  I know that fc7 live cd works just fine on my system.

 

Comment 2 Matěj Cepl 2007-03-26 11:36:34 EDT
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 3 Adam Jackson 2007-03-26 11:55:08 EDT
Also, please indicate whether this issue occurs when not using the Xen kernel.
Comment 4 Leslie Satenstein 2007-03-26 13:02:30 EDT
I did  all, as you requested, prior to writing this entry.

As you know, in Fc6, we can hit the icon during boot or the enter key during the
boot process and watch lines following udev present their list of messages
followed by ...[OK]

The process is 100 percent error free, until the logon screen is presented. 

Then poof, no keyboard lights, no mouse, and no graceful shutdown via the
momentary press of the poweroff key. It did not work with vesa being
substituted, it did not work without xorg.conf and essentially, I just did a
rollback to the previous kernel, which works just fine.

I am writing this from work, and will send the xorg.conf file tonight. Please
refer to the other bug report concerning x-windows, that I filed last November
and which was not answered.

The reason I did not pursue it, is that I did the exclude=*xorg* in yum.conf, so
my system was stable. And it was until I thought that I could remove the
exclude.  What a mistake....

FYI, My pc has two Fedora installations on separate hard disks. I wiped out one
FC6 and have installed FC7 (Rawhide). No problems there with rawhide test2
release, but the kernel upgrade with Rawhide locks up during the boot process at
the initialisation of ip tables.  Again, this note is a an aside for Rawhide.
X-windows in Rawhide works fine... bizzare ehh. 

I will backup my /usr/bin   fully and any other path before I remove the exclude
files. Just want to resolve the X-Windows Kernel bug problem.

Files will be sent to you tonight (Montreal time).


Since Fedora is a serious hobby for me, my wife was a little upset at the time I
invested, but, since I am addicted to linux, instead of bars and women, it was
my comprimise message to her. 



Comment 5 Leslie Satenstein 2007-03-26 20:24:39 EDT
Created attachment 150980 [details]
Xorg.conf file as requested

File 1 of three
Comment 6 Leslie Satenstein 2007-03-26 20:28:59 EDT
Created attachment 150981 [details]
xorg log file

One before and one more to come
Comment 7 Leslie Satenstein 2007-03-26 20:38:38 EDT
Created attachment 150983 [details]
xorg

I will install the Xen update, and advise of my experience with the indicated
software.

There is -rws--x--x 1 root root 1820676 Mar 15 22:18 Xorg that I have found,
and this version does not appear to crash my system.
Comment 8 Leslie Satenstein 2007-03-28 19:30:54 EDT
Tomorrow, March 29th is FC7 test3 release day. I had planned to install it. I
will delay doing that if you would like me to retain the problem linux system
for now.

Fc7 xen is not a priority, except that it appears to run well on my system
Comment 9 Leslie Satenstein 2007-03-30 13:09:33 EDT
I am adding this note to the bug. I am planning an install of Fc7 onto my
systems second hard disk. (my desktop has 2 hard disks). The primary one has the
latest 2933 kernels (xen and non xen). Both cause lockup beginning at the time
the logon prompt is offered.  An earlier version of xen (2911) would lock up
randomly, and occassionally with mouse scrolling. Where is the problem and why
does the vanilla fc6 release not have these problems?

If you do not require my preserving the system for some patch tests, please
advise. I would like to help you (and of course it helps me) to have a stable
reliable system.

Leslie in Montreal Canada
Comment 10 Leslie Satenstein 2007-04-05 19:55:35 EDT
System Lockup 

I posted this on linuxquestions.org as more users of Fedora are on it then
review the bug list.

This bug pertains to FC6 and FC7 with full X updates.  I have an intel
motherboard with the built-in i810 video.  With the non-Xen version of either
linux version, I can boot and run as one expects.  When I select the XEN version
of linux. the system boots, (I can watch it) and when it arrives to presenting
the logon prompt, there is a hard freeze. Sometimes I get the logo from the
Intel bios, indicating that the system crashed into the bios; sometimes, it is
dead, no mouse activity, no keyboard lights or keyboard operation.  Even the
power switch is disabled. (It takes a hard reset to restart).

The non-Xen versions appear to work fine.

And I am experiencing three problems with FC7 and Gnome, perhaps again due to X. 

The second problem is random.  If Evolution crashes, a restart is ok, but then
randomly, Gnome appears to fail. When it does, I can open menus, but clicking to
start a program does not work. ctl-alt-backspace restarts Gnome, but it remains
broken (unable to logon via ctl-alt-f1 too).  

Another quirky thing, is that randomly, Gnome will fail as above, but then the
icons on the desktop start to disappear as I try to click on them or slide a
window over one. I can then and do end up with a clean desktop. Since the mouse
and keyboard are active, the power-off button does signal a shutdown.  

Until these bugs get patches I will keep Fc6 for a reference (backup) only. Re
Fc7, I will not have to wait to May 24th for the official release. I like it.

I have sent logs, and I can work with your maintainer to test any patch. What is
good for my configuration is also good for certain Dell laptops too.
Comment 11 Leslie Satenstein 2007-04-29 18:59:46 EDT
WITH FC7 THE PROBLEM IS MORE SEVERE when the system is a dual core and the video
driver on the mother board is the i810. 

If Virtualisation is selected during installation, then the XEN kernel and
associated packages are loaded. A non-XEN kernel is not loaded as a backup.

When initialisation is completed, after install and during the boot process, the
system locks up deader than dead. I have not tried using linux rescue, and
chgimage to then load a normal kernel.

X works ok with the normal non XEN kernel. 

This problem is in FC7 and FC6.  By the way, another reminder. It does not seem
to appear with the Oct 24th release of FC6.  It is present in the Unity respins
of January 2007.  I identified that the problem manifested itself in November of
2006, after an XORG update.


Comment 12 Leslie Satenstein 2007-05-14 16:32:55 EDT
Created attachment 154684 [details]
FC7 Boot messages (log file)

Fc7 boot messages log file
Comment 13 Leslie Satenstein 2007-05-14 16:34:34 EDT
Created attachment 154685 [details]
The X windows log file up to the point of the crash.

The X windows log file up to the point of the crash.
Comment 14 Leslie Satenstein 2007-05-16 11:47:26 EDT
I did an update

It is fc7 test4, using the kernel listed below that is crashing

With the test version of XEN sent to me 

http://koji.fedoraproject.org/packages/kernel-xen-2.6/2.6.20/2925.8.fc7/
http://koji.fedoraproject.org/packages/xen/3.1.0/0.rc7.1.fc7/

It boots, sometimes stopping just before boot is complete, with only the 
hardware system reset button available (a hard lock occurs with no keyboard or 
mouse or power switch functioning with the kernel) 

Now mainly it executes to where the Gnome prompt is presented. On reboot, 
journal files fix up takes place.

When lockup occurs, one cannot log into the system (no keyboard, no mouse, and 
no power off switch functionable to trigger a shutdown). I have also re-tried 
it switching from X windows i810 driver to the vesa driver, with same problem. 
Repeat, on system freeze, the only recourse is to hit the hardware system reset 
button or depress the hardware power off switch for 5 seconds, and then reboot.

 

No problems booting with non-xen kernel.

What can I do to help? I sent log files and
 
Comment 15 Leslie Satenstein 2007-06-01 16:42:23 EDT
Andrew,
Congratulations. For the first time since November last, I am able to boot XEN,
and it did not crash, lockup, or set my computer on fire (cpu = 100%, with fan
running at 100%).

As far as I am concerned, XEN is now not a bug

For the record FC7 XEN runs on 

Mother Board     Intel d945gnt
Processor        Intel d930
Memory           1 gig ddr2
Hard disk        200 gig ide (Maxtor)


Comment 16 Leslie Satenstein 2007-06-01 16:45:20 EDT
Also thank you to Ehabkost. What first name does E represent?


Note You need to log in before you can comment on or make changes to this bug.