Bug 233966 - Support for reading read-only configuration files
Support for reading read-only configuration files
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ghostscript (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
: Reopened
Depends On:
Blocks: FC7Target
  Show dependency treegraph
 
Reported: 2007-03-26 08:19 EDT by Akira TAGOH
Modified: 2008-08-02 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version: 8.15.4-3.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-17 06:13:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed patch for ghostscript.spec (1.62 KB, patch)
2007-03-26 08:49 EDT, Akira TAGOH
no flags Details | Diff
new file (CIDFnmap) to be installed under /usr/share/ghostscript/8.15/lib/ (291 bytes, application/octet-stream)
2007-04-17 01:36 EDT, Akira TAGOH
no flags Details
updated FAPIcidfnmap (422 bytes, application/octet-stream)
2007-04-17 01:37 EDT, Akira TAGOH
no flags Details
an replacement of Fontmap that gs has by default. (138 bytes, application/octet-stream)
2007-04-17 01:37 EDT, Akira TAGOH
no flags Details
updated cidfmap (398 bytes, application/octet-stream)
2007-04-17 01:38 EDT, Akira TAGOH
no flags Details

  None (edit)
Description Akira TAGOH 2007-03-26 08:19:25 EDT
Description of problem:
Sorry for getting back this idea again, but adding the another configuration
files to Fontmap, FAPIfontmap, FAPIcidfmap, cidfmap and CIDFnmap to read is
required for silly packaging issue. where is put onto the directory that isn't
allowed to modify in general, such as /usr/share.

Will attach the proposed patch then.
Comment 1 Akira TAGOH 2007-03-26 08:36:08 EDT
I mean /etc/ghostscript would be used as the place put the user configuration
and create new place to put the files which the packages, such as
fonts-{japanese,korean,chinese} has.
Comment 2 Akira TAGOH 2007-03-26 08:49:41 EDT
Created attachment 150891 [details]
proposed patch for ghostscript.spec

The reason to put the user configuration files under the versioned directory is
to prevent the breakage for incompatible changes in the configuration since it
may be hard to solve such files but we could fix the configuration files from
the font packages with rebuilding them. and still adding /etc/ghostscript to
the font path is to keep the compatibility. %{_datadir}/%{name}/conf.d would be
used to put the files for the font packages.
Comment 3 Tim Waugh 2007-04-03 09:33:13 EDT
This hunk did not apply cleanly:

@ -110,7 +110,9 @@
 	%{_datadir}/fonts/default/amspsfnt/pfb \
 	%{_datadir}/fonts/default/cmpsfont/pfb \
 	%{_datadir}/fonts/japanese \
-	%{_sysconfdir}/%{name}
+	%{_datadir}/%{name}/conf.d \
+	%{_sysconfdir}/%{name} \
+	%{_sysconfdir}/%{name}/%{gs_dot_ver}
 do
   FONTPATH="$FONTPATH${FONTPATH:+:}$path"
 done

..because %{_datadir}/fonts/japanese is not in that list in CVS.  Is that part
of a different change?
Comment 4 Tim Waugh 2007-04-03 09:37:11 EDT
Oh, never mind, I was looking at a CVS file with a sticky tag..
Comment 5 Akira TAGOH 2007-04-10 08:44:08 EDT
Sorry for reopening. but need to append the kind of (cidfmap.local)
.runlibfileifexists in cidfmap say. and as well as in CIDFnmap, FAPIfontmap and
Fontmap.
Comment 6 Tim Waugh 2007-04-10 09:31:49 EDT
Could you provide a patch please?  I'm not sure I understand enough about it to
get it right..
Comment 7 Akira TAGOH 2007-04-17 01:36:17 EDT
Created attachment 152763 [details]
new file (CIDFnmap) to be installed under /usr/share/ghostscript/8.15/lib/
Comment 8 Akira TAGOH 2007-04-17 01:37:06 EDT
Created attachment 152764 [details]
updated FAPIcidfnmap
Comment 9 Akira TAGOH 2007-04-17 01:37:53 EDT
Created attachment 152765 [details]
an replacement of Fontmap that gs has by default.
Comment 10 Akira TAGOH 2007-04-17 01:38:44 EDT
Created attachment 152766 [details]
updated cidfmap
Comment 11 Tim Waugh 2007-04-17 06:13:10 EDT
Thanks!  Should be all done in ghostscript-8.15.4-3.fc7.

Note You need to log in before you can comment on or make changes to this bug.