Bug 23399 - TI925DC: cache problems
Summary: TI925DC: cache problems
Status: CLOSED CURRENTRELEASE
Alias: None
Product: eCos
Classification: Retired
Component: HAL (Show other bugs)
(Show other bugs)
Version: CVS
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: ecc-bugs-int
QA Contact: ecc-bugs-int
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-05 09:45 UTC by Jesper Skov
Modified: 2007-04-18 16:30 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-28 07:10:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jesper Skov 2001-01-05 09:45:16 UTC
Never got the caches on the OMAP to work properly - missing some detailed
info from TI (which has been requested).

Impact flash programming / performance overall, since it results in not
being able to safely disable/enable caches while programming flash.
Workaround is to leave caches disabled, but this results in horrible
performance.

Comment 1 Jesper Skov 2001-05-28 07:09:59 UTC
Interestingly, Gary also failed to make D-caches work on some other ARM9
variant. Appears there's some magic required in flushing/clearing the
D-cache on this variant of the ARM.


Comment 2 Jesper Skov 2001-12-03 11:29:38 UTC
This turned out to be a bad limit in one of the ARM9 HAL's cache handling loops.



Note You need to log in before you can comment on or make changes to this bug.