Bug 2340 - gdm crashes with face browser
Summary: gdm crashes with face browser
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: distribution   
(Show other bugs)
Version: 5.2
Hardware: alpha
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jonathan Blandford
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-04-23 14:41 UTC by pablo
Modified: 2013-04-02 04:13 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-07-29 15:58:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description pablo 1999-04-23 14:41:17 UTC
(Note: there's no component gdm in the bug reporting
form, so I selected gnome. I think there should be a way
to enter an arbitrary package name...)

Tried the gdm--1.0.0-12rh.alpha.rpm package "retro-shipped"
for 5.2 by rhad. If I enable the face browsing capacity and save
JPEG pictures to user's home pages, gdm crashes. (Not sure
if it's alpha specific problem, haven't tried on i386)

Crashing gdm (or xdm etc) is really a pain in the ass,
at least if it's starting from /etc/inittab, since it causes
X to be restarted in a loop and on a standalone machine
(no ssh/telnet available) you can't do anything
but reboot (using SysRq magic if you're lucky...otherwise
with the reset button :-(). A solution to this problem would
be important, especially if RH will be shipped in the future
with xdm/gdm starting by default! People with bad X configuration etc will also suffer this restart-loop.

Comment 1 Michael Fulbright 1999-05-26 14:26:59 UTC
Browsing is not a recommended feature (has bad security implications
in a public environment), but we will be looking at the problem
reported.

Comment 2 Jonathan Blandford 1999-07-07 15:43:59 UTC
This has been fixed, and is in Raw Hide.

Comment 3 Elliot Lee 1999-07-29 15:58:59 UTC
Close bugs when you fix them... :)


Note You need to log in before you can comment on or make changes to this bug.